Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Core Classes/Modules
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Not sure why this is happening, but I have to mask this test in 1.9 mode.

        5) Failure:
      test_thread_local_variables(TestThread) [/Users/headius/projects/jruby/test/test_thread.rb:48]:
      <[:x, :y]> expected but was
      <[:__recursive_key__, :x, :y]>.
      
      

        Activity

        Charles Oliver Nutter added a comment -

        This comes from the 1.9 implementation of "pp", which uses a thread-local hash to monitor recursion. It does not remove this hash from the thread locals, but it does pop elements off, effectively clearing it.

        Calling this not a bug, since it's just a somewhat icky optimization to leave it in place, and it's from stdlib anyway.

        Charles Oliver Nutter added a comment -

        I modified the test to be more permissive of keys leftover in the threadlocals.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Charles Oliver Nutter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: