JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6450

jruby-win32ole fails under java7 and jruby master; can't find org.jruby.runtime.builtin.IRubyObject.toJava(Class)int

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: win32ole 0.8.4, JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Compiler, win32ole, Windows
    • Labels:
      None
    • Environment:
      win7 x64, java7u2, jruby-win32ole 0.8.5 (not an option on the "affects versions" drop-down menu)
    • Number of attachments :
      2

      Description

      Please look at the screen shots. The stack is large so I provided a screen shot of the top of the backtrace and the bottom where it says "Caused by:"

        Activity

        Charles Oliver Nutter added a comment -

        I broke indy stuff recently...will get around to fixing it once 1.6.7 is out.

        Thomas E Enebo added a comment -

        Resolving this for now...since reported there has been an immense number of changes to invokedynamic code. Chuck, if this is still an issue you can open a new issue, but perhaps ping headius first.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Chuck Remes
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: