Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Incomplete
    • Affects Version/s: JRuby 1.6.5
    • Fix Version/s: None
    • Component/s: Rails WAR Deployment
    • Labels:
      None
    • Environment:
      Ubuntu 11.10
      Linux icf109118-Ubuntu 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
      jruby 1.6.5.1 (ruby-1.8.7-p330) (2011-12-27 1bf37c2) (OpenJDK 64-Bit Server VM 1.6.0_23) [linux-amd64-java]
    • Number of attachments :
      3

      Description

      Warbler has given me this error intermittently in the past, but yesterday and today, I can't get past it.

      I can't reproduce this on a fresh new Rails project, unfortunately, it's just my existing app that's having problems.

      1. stacktrace.txt
        12 kB
        Jamie Jackson
      2. warble.rake
        0.1 kB
        Jamie Jackson
      3. warble.rb
        6 kB
        Jamie Jackson

        Activity

        Jamie Jackson added a comment -

        Exists under 1.6.6, as well.

        Jamie Jackson added a comment -

        If anybody's got a workaround, I'd appreciate it. I'm stuck. (Can't deploy.)

        Nick Sieger added a comment -

        Looks like there's some circularity between lib/tasks/warble.rake and something in your config/warble.rb file. Can you attach those?

        Jamie Jackson added a comment -

        config/warble.rb

        Jamie Jackson added a comment -

        lib/tasks/warble.rake

        Nick Sieger added a comment -

        I think I see what the problem is. You're running the "warble" command when you also have tasks defined in warble.rake. Hopefully I can detect this and prevent the issue from happening or present a better error message. Leaving this open to fix.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Jamie Jackson
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: