JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6411

gem install failing with "marshal data too short" on Windows x64

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.6
    • Fix Version/s: JRuby 1.6.7
    • Component/s: None
    • Labels:
    • Environment:
      Windows Server 2008 R2 x64, JRuby 1.6.6
    • Number of attachments :
      0

      Description

      Trying to install certain gems (e.g. rails) with JRuby 1.6.6 on Windows Server 2008 x64 fails:

      jruby -S gem install rails
      ERROR: While executing gem ... <ArgumentError>
      marshal data too short

      Trying to install the gem with Bundler throws the same error, but with a stack trace:

      jruby -S bundle install
      ArgumentError: marshal data too short
      load at org/jruby/RubyMarshal.java:150

      At the moment I can only reproduce this on a Windows 2008 R2 x64 machine. On a similar 32-bit installation it works flawlessly. Don't know if that could be a reason.

        Activity

        Charles Oliver Nutter added a comment -

        Hmm, I would not expect 32 vs 64-bit to cause a problem, but stranger things have happened.

        Would it be possible for you to run this again, passing the flag -Xbacktrace.style=raw to JRuby (or -J-Djruby.backtrace.style=raw to java) so we can get a more complete trace? You should also be able to get a longer trace from rubygems by passing --trace or --debug (I forget which).

        Without being able to reproduce this we will have to depend on you to investigate. Sorry this got missed...we're doing JRuby 1.6.7 this week, so there's a time crunch now.

        Hiro Asari added a comment -

        It works for me on the 1.6 branch:

        C:\Users\asari\Development\src\jruby>.\bin\jruby --1.9 -v
        jruby 1.6.7.dev (ruby-1.9.2-p312) (2012-02-14 29d31bd) (Java HotSpot(TM) 64-Bit Server VM 1.6.0_29) [Windows 7-amd64-java]
        
        C:\Users\asari\Development\src\jruby>.\bin\jruby --1.9 -S gem install rails
        Fetching: i18n-0.6.0.gem (100%)
        Fetching: multi_json-1.0.4.gem (100%)
        Fetching: activesupport-3.2.1.gem (100%)
        Fetching: builder-3.0.0.gem (100%)
        Fetching: activemodel-3.2.1.gem (100%)
        Fetching: rack-1.4.1.gem (100%)
        Fetching: rack-cache-1.1.gem (100%)
        Fetching: rack-test-0.6.1.gem (100%)
        Fetching: journey-1.0.1.gem (100%)
        Fetching: hike-1.2.1.gem (100%)
        Fetching: tilt-1.3.3.gem (100%)
        Fetching: sprockets-2.1.2.gem (100%)
        Fetching: erubis-2.7.0.gem (100%)
        Fetching: actionpack-3.2.1.gem (100%)
        Fetching: arel-3.0.0.gem (100%)
        Fetching: tzinfo-0.3.31.gem (100%)
        Fetching: activerecord-3.2.1.gem (100%)
        Fetching: activeresource-3.2.1.gem (100%)
        Fetching: mime-types-1.17.2.gem (100%)
        Fetching: polyglot-0.3.3.gem (100%)
        Fetching: treetop-1.4.10.gem (100%)
        Fetching: mail-2.4.1.gem (100%)
        Fetching: actionmailer-3.2.1.gem (100%)
        Fetching: rake-0.9.2.2.gem (100%)
        Fetching: thor-0.14.6.gem (100%)
        Fetching: rack-ssl-1.3.2.gem (100%)
        Fetching: json-1.6.5-java.gem (100%)
        Fetching: rdoc-3.12.gem (100%)
        Depending on your version of ruby, you may need to install ruby rdoc/ri data:
        
        <= 1.8.6 : unsupported
         = 1.8.7 : gem install rdoc-data; rdoc-data --install
         = 1.9.1 : gem install rdoc-data; rdoc-data --install
        >= 1.9.2 : nothing to do! Yay!
        Fetching: railties-3.2.1.gem (100%)
        Fetching: bundler-1.0.22.gem (100%)
        Fetching: rails-3.2.1.gem (100%)
        Successfully installed i18n-0.6.0
        Successfully installed multi_json-1.0.4
        Successfully installed activesupport-3.2.1
        Successfully installed builder-3.0.0
        Successfully installed activemodel-3.2.1
        Successfully installed rack-1.4.1
        Successfully installed rack-cache-1.1
        Successfully installed rack-test-0.6.1
        Successfully installed journey-1.0.1
        Successfully installed hike-1.2.1
        Successfully installed tilt-1.3.3
        Successfully installed sprockets-2.1.2
        Successfully installed erubis-2.7.0
        Successfully installed actionpack-3.2.1
        Successfully installed arel-3.0.0
        Successfully installed tzinfo-0.3.31
        Successfully installed activerecord-3.2.1
        Successfully installed activeresource-3.2.1
        Successfully installed mime-types-1.17.2
        Successfully installed polyglot-0.3.3
        Successfully installed treetop-1.4.10
        Successfully installed mail-2.4.1
        Successfully installed actionmailer-3.2.1
        Successfully installed rake-0.9.2.2
        Successfully installed thor-0.14.6
        Successfully installed rack-ssl-1.3.2
        Successfully installed json-1.6.5-java
        Successfully installed rdoc-3.12
        Successfully installed railties-3.2.1
        Successfully installed bundler-1.0.22
        Successfully installed rails-3.2.1
        31 gems installed
        

        Can you try the snapshot? http://ci.jruby.org/snapshots/release/

        Do you set environment variables? What is your language setting?

        Charles Oliver Nutter added a comment -

        Could not reproduce with a more recent release and no follow-up from the reporter. Marking fixed in 1.6.7.

        Charles Oliver Nutter made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Thomas E Enebo [ enebo ] Charles Oliver Nutter [ headius ]
        Fix Version/s JRuby 1.6.7 [ 18315 ]
        Resolution Fixed [ 1 ]
        Charles Oliver Nutter made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Robert Glaser
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: