Details

    • Type: Epic Epic
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      We've heard some interest from the users that we should switch the default language mode to 1.9.

      We should decide if 1.7 is the one to make the switch.

        Activity

        Hide
        Peter Fitzgibbons added a comment -

        +1 Yes

        Show
        Peter Fitzgibbons added a comment - +1 Yes
        Hide
        Cristian Molina added a comment -

        Yes!, of course!

        Show
        Cristian Molina added a comment - Yes!, of course!
        Hide
        Charles Oliver Nutter added a comment -

        It is done.

        commit 3163d6ca94ccc8fd33851896614a42c29b2e5ec6
        Author: Charles Oliver Nutter <headius@headius.com>
        Date:   Fri Jan 27 11:37:17 2012 -0600
        
            Switch default Ruby mode to 1.9.
        
        diff --git a/default.build.properties b/default.build.properties
        index fa4d03c..53f23a7 100644
        --- a/default.build.properties
        +++ b/default.build.properties
        @@ -98,4 +98,4 @@ mac.dist=${build.dir}/jruby-${version.jruby}
         dist.zip=${dist.dir}/jruby-bin-${version.jruby}.zip
         gems.dist.dir=${build.dir}/gems_dist
         gems.defaults.dir=${mac.dist}/lib/ruby/shared/rubygems/defaults
        -jruby.default.ruby.version=1.8
        +jruby.default.ruby.version=1.9
        
        Show
        Charles Oliver Nutter added a comment - It is done. commit 3163d6ca94ccc8fd33851896614a42c29b2e5ec6 Author: Charles Oliver Nutter <headius@headius.com> Date: Fri Jan 27 11:37:17 2012 -0600 Switch default Ruby mode to 1.9. diff --git a/default.build.properties b/default.build.properties index fa4d03c..53f23a7 100644 --- a/default.build.properties +++ b/default.build.properties @@ -98,4 +98,4 @@ mac.dist=${build.dir}/jruby-${version.jruby} dist.zip=${dist.dir}/jruby-bin-${version.jruby}.zip gems.dist.dir=${build.dir}/gems_dist gems.defaults.dir=${mac.dist}/lib/ruby/shared/rubygems/defaults -jruby.default.ruby.version=1.8 +jruby.default.ruby.version=1.9
        Hide
        Youhei Kondou added a comment -

        I hope 1.9

        Show
        Youhei Kondou added a comment - I hope 1.9
        Hide
        Darrick Wiebe added a comment -

        Victory!!

        Show
        Darrick Wiebe added a comment - Victory!!

          People

          • Assignee:
            Thomas E Enebo
            Reporter:
            Hiro Asari
          • Votes:
            20 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: