Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.5
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: C Extensions
    • Labels:
      None
    • Number of attachments :
      1

      Description

      I believe we can ignore the fact that this is being invoked from within a community-ruby build. I have not gotten an image to confirm this and it was only reported for 1.6.5.1 build.

      g++ -m64 -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing -W -Wall -Wno-unused -Wno-parentheses -Werror -Wundef -I"/space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src/../..//build" -I"/space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src" -I"/space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src/../..//build"/jni -I"/space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src"/include -I"/space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src"/include/ruby -fPIC -I"/space/jdk/include" -I"/space/jdk/include/linux" -D_REENTRANT -D_LARGEFILE64_SOURCE -D_GNU_SOURCE -pthread -c /space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src/thread.cpp -o /space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src/../..//build/thread.o
      make[1]: Leaving directory `/space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src'
      /space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src/thread.cpp: In function 'int rb_thread_select(int, fd_set*, fd_set*, fd_set*, timeval*)':
      /space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src/thread.cpp:92:26: error: cast to pointer from integer of different size [-Werror=int-to-pointer-cast]
      cc1plus: all warnings being treated as errors
      make[1]: *** [/space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/cext/src/../..//build/thread.o] Error 1
      make: *** [all] Error 2
      
      BUILD FAILED
      /space/src/nb/community-ruby/.hg/nb/harness/suite.xml:184: The following error occurred while executing this line:
      /space/src/nb/community-ruby/o.jruby.distro/build.xml:86: The following error occurred while executing this line:
      /space/src/nb/community-ruby/o.jruby.distro/build.xml:71: The following error occurred while executing this line:
      /space/src/nb/community-ruby/o.jruby.distro/unpatched_source/jruby-1.6.5.1/build.xml:1706: exec returned: 2
      
      This on 64-bit Ubuntu Oneiric. Just FYI.
      
      1. jruby6378.patch
        0.7 kB
        Sébastien Le Callonnec

        Activity

        Sébastien Le Callonnec added a comment - - edited

        I can confirm the issue, I can reproduce it on master HEAD with Oneiric 64bits.
        The attached patch solves the problem, but I wouldn’t mind another pair of eyes on it, as I’m quite green in C++...

        Tim Felgentreff added a comment -

        I applied this patch and it works for me now, Tom, can you close?

        Hiro Asari added a comment -

        I cherry-picked it to the 1.6 branch as well.


          People

          • Assignee:
            Thomas E Enebo
            Reporter:
            Thomas E Enebo
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: