Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.7.0.RC1
    • Component/s: Projects
    • Labels:
      None
    • Environment:
      OpenJDK Server 1.7u2, self-compiled, 32-bit Debian Linux system, 4G of RAM
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      https://github.com/whitequark/furnace-avm2

      @headius knows what this is all about.

        Activity

        Charles Oliver Nutter added a comment -

        Is there any way I can reproduce this? There are now builds of the new invokedynamic logic in OpenJDK, and we could help the Hotspot team by testing your stuff out and reporting performance numbers.

        Peter Zotov added a comment -

        I think I cannot reproduce it anymore on latest JRE (u5) and JRuby. I'll reopen the bug if it will remanifest itself. I'm regularly running performance tests on JRuby head.

        Charles Oliver Nutter added a comment -

        Great, thank you. If you're interested, I can get you access to the new invokedynamic logic slated for Java 8 (and hopefully Java 7 update 8), which has not yet been optimized but which should eventually optimize much better than the current logic. Find me on IRC if you're interested.

        Charles Oliver Nutter added a comment -

        We'll call this fixed in RC1.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Peter Zotov
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: