JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6359

Can't convert nil to String building ActiveSupport RDoc in 1.9 mode

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.6, JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.6.6
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Continuation of JRUBY-5808...

      system ~/projects/jruby2 $ jruby --1.9 -S gem install --rdoc --ri activesupport
      Fetching: multi_json-1.0.4.gem (100%)
      Fetching: activesupport-3.1.3.gem (100%)
      Successfully installed multi_json-1.0.4
      Successfully installed activesupport-3.1.3
      2 gems installed
      Installing ri documentation for multi_json-1.0.4...
      
      RDoc::Parser::Ruby failure around line 1 of
      lib/multi_json/engines/json_common.rb
      
      Before reporting this, could you check that the file you're documenting
      has proper syntax:
      
        /Users/headius/projects/jruby2/bin/jruby -c lib/multi_json/engines/json_common.rb
      
      RDoc is not a full Ruby parser and will fail when fed invalid ruby programs.
      
      The internal error was:
      
      	(TypeError) can't convert nil into String
      
      ERROR:  While generating documentation for multi_json-1.0.4
      ... MESSAGE:   can't convert nil into String
      ... RDOC args: --ri --op /Users/headius/projects/jruby2/lib/ruby/gems/1.8/doc/multi_json-1.0.4/ri --charset=UTF-8 lib LICENSE.md README.md --title multi_json-1.0.4 Documentation --quiet
      

        Activity

        Charles Oliver Nutter added a comment -

        This was caused by recent fixes to 1.9-mode Array#join. The Array "join_0" method from MRI was ported incorrectly, and attempted to coerce the 0 element of the backing store rather than the "begin" element. In COW cases, this element would be nil, causing the error.

        Fixed on master@cf9b95d and jruby-1_6@07c4ab1.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Charles Oliver Nutter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: