JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6262

JRuby Installation Fails with "execv failed: Permission denied (13)" (even when Installing as root)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: JRuby 1.6.1
    • Fix Version/s: JRuby 1.6.1
    • Component/s: Launcher
    • Labels:
    • Environment:
      Linux 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:25:36 UTC 2011 i686 i686 i386 GNU/Linux
      DISTRIB_ID=Ubuntu
      DISTRIB_RELEASE=11.10
      DISTRIB_CODENAME=oneiric
      DISTRIB_DESCRIPTION="Ubuntu 11.10"
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      # rvm install jruby
      jruby-1.6.1 - #fetching 
      jruby-1.6.1 - #extracting jruby-bin-1.6.1 to /usr/share/ruby-rvm/src/jruby-1.6.1
      jruby-1.6.1 - #extracted to /usr/share/ruby-rvm/src/jruby-1.6.1
      Building Nailgun
      jruby-1.6.1 - #installing to /usr/share/ruby-rvm/rubies/jruby-1.6.1
      ERROR: Cannot switch to 1.6.2 for this interpreter.
      jruby-1.6.1 - #importing default gemsets (/usr/share/ruby-rvm/gemsets/)
      Copying across included gems
      execv failed: Permission denied (13)
      

        Activity

        Hiro Asari added a comment -

        The error is coming from RVM. Please ask for help from them.

        Hiro Asari added a comment -

        Resolving as incomplete.

        Michal Papis added a comment -

        @asari: I guess you took time to trace it back to RVM, any clue where should I start? (https://github.com/wayneeseguin/rvm/issues/944)

        Hiro Asari added a comment -

        Michal,

        I am not completely familiar with what RVM does, but the command proceeds to install to a directory under usr/share/ruby-rvm, and copy gems. JRuby does not do these things.

        We do not issue error message such as

        ERROR: Cannot switch to 1.6.2 for this interpreter.
        

        If the user is getting permission errors, there are directories or files with insufficient privileges for the user who's running it.

        If execv is getting EPERM, the chances are, there is a file without execute permission which something (and I am guessing it is a shell script via RVM) is trying to run.

        Michal Papis added a comment -

        Hiro I think I need some help from you on debugging this, I have few more informations.

        In this gist https://gist.github.com/770188 I see

        jruby-1.5.6 16:47 ~ $ jruby
        execv failed: Permission denied (13)

        I was trying on my system and it works nice with RVM, the jruby is an executable file ...
        this means for me that the real problem happens in a jruby binary file which is out of my debugging capabilities.

        Hiro Asari added a comment -

        Ah. I overlooked that part.

        I am reopening this for now, but I suspect there is a problem with David's setup.

        I commented on the original gist, but I reproduce it here as well:

        What we can't tell from the execv error message above is what file is giving you the EACCESS. Can you try strace -f jruby to see which file is actually giving you this error message?

        Hiro Asari added a comment -

        We can't reproduce this problem.


          People

          • Assignee:
            Hiro Asari
            Reporter:
            David L. Sieving
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: