Details

    • Type: Task Task
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.5
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Suse Linux SLES 11-SP2 on s390x architecture (64 bit)
    • Number of attachments :
      1

      Description

      Apologies if this is not the right venue to post this question. I am trying to build the binaries for JFFI for the s390x architecture for JFFI 1.0.2 but receive the following error when I run 'ant jar test' and receive the following error after a while:

      -build-native-library:
      [exec] env: /bsc/jruby/jffi-1.0.2/jni/libffi/configure: No such file or directory
      [exec] make: *** [/bsc/jruby/jffi-1.0.2/build/jni/libffi-s390x-linux/.libs/libffi_convenience.a] Error 127
      [exec] Configuring libffi for s390x-linux

      BUILD FAILED
      /bsc/jruby/jffi-1.0.2/custom-build.xml:125: exec returned: 2

      Can someone describe how ones goes about building binaries for specific architectures?

      Thanks.

        Activity

        Charles Oliver Nutter added a comment -

        This probably isn't the best place for this question, but there's no issues support at the actual project (https://github.com/jnr/jffi).

        I'll call Wayne's attention to this issue.

        If you're able to investigate yourself, look under the jni/ subdir and see if you can get things to configure and (attempt to) build without using ant.

        Aria Bamdad added a comment -

        Charles, thanks for your reply. My jni directory contains an executable 'GNUmakefile' and the following directories: build, jffi, libffi and win32.the build directory has an empty subdirectory of libffi-s390x-linux.

        Where can I find instructions on how to manually configure?

        Aria Bamdad added a comment -

        Ok, I got past that error by downloading the libffi source into the /ffi-1.0.2/jni/jffi directory and running configure and make. Then issuing 'ant jar test' goes further and fails on:

        -do-jar-with-libraries:

        -do-jar-with-libraries-without-mainclass:

        -do-jar-with-libraries-without-manifest:

        BUILD FAILED
        /bsc/jruby/jffi-1.0.2/nbproject/build-impl.xml:555: taskdef class org.netbeans.modules.java.j2seproject.copylibstask.CopyLibs cannot be found
        using the classloader AntClassLoader[]

        Aria Bamdad added a comment -

        Success!

        The above error was caused by a missing org-netbeans-modules-java-j2seproject-copylibstask.jar file in my /jffi-1.0.2/lib/CopyLibs directory. In fact, this directory was empty. I found a copy of this jar file in here http://pkgs.fedoraproject.org/repo/pkgs/jffi/

        I now have a jffi-s390x-Linux.jar in my dist directory for jffi.

        How and where can I contribute this for inclusion in future jruby distributions?

        Thanks,

        Wayne Meissner added a comment -

        I'm a bit late, but there should be a s390x-Linux build already in the archive directory in jffi (as checked out from github) - but I hadn't pushed it yet.

        Try that one first, and if it doesn't work for you (not sure what Linux it was built on), then attach a build from the latest jffi source to this ticket, and I'll include it in the next release.

        That same build should already be in jruby-master/build_lib/jffi-s390x-Linux.jar

        Aria Bamdad added a comment -

        Hi Wayne,

        The archive directory you mention contains jars for various distributions but the jar files for the s390x and ppc64 appear to be empty (only 114 bytes file size).

        I downloaded the jffi 1.0.10 archive and did the following 'ant clean', 'ant compile' and 'ant jar'. I ended up with a new jffi-s390x-Linux.jar in the dist directory which I will attach here.

        Will this jar file need to be compiled for each new version of jffi?
        Will this work its way into JRuby because it is jruby that I am trying to get working on s390x?

        Thanks for your help.

        Aria Bamdad added a comment -

        Built for s390x architecture using SUSE SLES 11 sp1 and jffi 1.0.10.

        Aria Bamdad added a comment -

        Hi Wayne,

        Are you able to include the attached binary in your latest release?

        Charles Oliver Nutter added a comment -

        It appears to be there on master...I'm marking this resolved. You can try a master build of JRuby from http://ci.jruby.org/snapshots.

        system ~/projects/jruby $ ls -l lib/native/s390x-Linux/libjffi-1.0.so 
        -rw-r--r--  1 headius  staff  92872 Aug 22 16:44 lib/native/s390x-Linux/libjffi-1.0.so
        

          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Aria Bamdad
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: