Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: JRuby 1.6.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      From https://aptanastudio.tenderapp.com/discussions/problems/3334-cannot-install

      An error occurred while processing the invoke block for the command Install Bundle in U:\3.7\configuration\org.eclipse.osgi\bundles\1519\1.cp\bundles\bundle-development.ruble\commands\install_bundle.rb: (TypeError) cannot convert instance of class org.jruby.java.proxies.ConcreteJavaProxy to interface org.eclipse.jface.viewers.IStructuredContentProvider 
      org.jruby.exceptions.RaiseException: (TypeError) cannot convert instance of class org.jruby.java.proxies.ConcreteJavaProxy to interface org.eclipse.jface.viewers.IStructuredContentProvider
      at #<Class:0x1011f84de>.request_item(U:/3.7/configuration/org.eclipse.osgi/bundles/1520/1/.cp/framework/ruble/ui.rb:147)
      at #<Class:0x10018f9d7>.define_command(U:\3.7\configuration\org.eclipse.osgi\bundles\1519\1\.cp\bundles\bundle-development.ruble\commands\install_bundle.rb:51)
      at org.jruby.RubyProc.call(org/jruby/RubyProc.java:268)
      at org.jruby.RubyProc.call(org/jruby/RubyProc.java:232)
      

      The code in question is, specifically line 2 here:

      ui.rb
      dialog = org.eclipse.ui.dialogs.ListDialog.new(shell)
      dialog.content_provider = org.eclipse.jface.viewers.ArrayContentProvider.new
      dialog.label_provider = org.eclipse.jface.viewers.LabelProvider.new
      dialog.input = items
      

      in ListDialog, here's the method being called:

      ListDialog.java
      public void setContentProvider(IStructuredContentProvider sp) {
        fContentProvider = sp;
      }
      

        Activity

        Charles Oliver Nutter added a comment -

        Im going to resolve this as "cannot reproduce" for now. The error in question should only happen if the object actually can't be cast to the interface in question. This can happen if the interface was loaded from a sibling classloader to the object's type's class, or obviously if the object actually doesn't implement the interface.

        Either way, please re-test with a more recent JRuby version (1.6.6.dev ideally, from http://ci.jruby.org/snapshots) and if you still have a problem we can dig into it.

        Peter Juhl Christiansen added a comment -

        I was just now able to reproduce this error. The issues was seen by updating from 1.5.6 where the code is working and well tested, but gives this error on 1.6.7. Unfortunately the code is running in a complicated setup, so at pressent I cant submit an example.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Christopher Williams
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: