JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6181

SSH Agent forwarding does not work with jRuby (which lets capistrano ssh-deployments fail)

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: JRuby 1.7.0.pre2
    • Component/s: OpenSSL
    • Labels:
      None
    • Environment:
      Jruby-1.6.5
    • Testcase included:
      yes
    • Number of attachments :
      4

      Description

      Unfortunately, the agent forwarding option seems to fail using jRuby.
      Capistrano deployments won't work if you're using ssh transport for git in combination with agent forwarding.
      The connection simply hangs.

      Attached you'll find a simple case which works in MRI and hangs in jRuby.

      Best,

      Tobias

      1. jruby_1_7_pre2_dev_net_ssh_test.dump
        17 kB
        Frazer
      2. jruby-6181-trace.txt
        330 kB
        Kevin Menard
      3. test.rb
        0.2 kB
        Tobias Schlottke
      4. threaddump-1320528062126.tdump
        25 kB
        Hiro Asari

        Activity

        Kevin Menard added a comment -

        I'm unable to reproduce the issue with the latest 1.7 nightly (2012-07-26 16d6869).

        Charles Oliver Nutter added a comment -

        Huzzah!

        Frazer added a comment -

        Hmm, Im still having an issue. Maybe I'm missing something. Attached dump.

        Kevin Menard added a comment -

        Frazer, I wonder if your issue might be JDK 6 vs JDK 7. I've run into weird issues with JDK 6 blocking indefinitely in PKCS stuff outside of JRuby.

        Frazer added a comment -

        Ah, thanks Kevin, I wouldn't mind betting thats it. I'll give 7 a shot.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Tobias Schlottke
          • Votes:
            7 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: