JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6180

"SystemCallError: Unknown error - Connection reset by peer" should be mapped to Errno::ECONNRESET

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.5
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Application Error
    • Labels:
      None
    • Number of attachments :
      1

      Description

      It appears that the Java error "SystemCallError: Unknown error - Connection reset by peer" doesn't map to Errno::ECONNRESET.

      I suspect that the same thing needs to be done that was done in JRUBY-4685.

      The commit is here: https://github.com/jruby/jruby/commit/6e8d0d52375859371cdbfb8c3ed99a29765dfdd7

        Activity

        Hiro Asari added a comment -

        I pushed a potential fix to the master branch (0ae6d45). Please test it.

        Dwayne Litzenberger added a comment -

        It works for me on Mac OS X (10.6.8), but not on Windows.

        Dwayne Litzenberger added a comment - - edited

        I've attached a patch that fixes JRUBY-6180 on Windows. To apply it, run:

        git am 0001-Also-fix-JRUBY-6180-on-Windows.patch
        
        Hiro Asari added a comment -

        I applied Dwayne's patch to master (c725e7d).

        Tyler Brock added a comment -

        I can confirm this doesn't work in 1.6.7 on Linux with Ubuntu 12.04 also.

        Should raise Errno::ECONNRESET but instead raises SystemCallError(<Unknown error - Connection reset by peer>)


          People

          • Assignee:
            Hiro Asari
            Reporter:
            Christian Höltje
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: