Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.4
    • Fix Version/s: JRuby 1.6.5
    • Component/s: Standard Library
    • Environment:
    • Number of attachments :
      0

      Description

      Simply, this is a new PC. Windows 7 and Java 6 and Java 7 (interchangeable)

      JRuby fails to connect with the Java 7 and works with Java 6!

      • Example: ruby gems install rake ...

      1/. (Java 7 – Fails)

      z:...> jruby -S gem install rake
      ERROR:  Could not find a valid gem 'rake' (>= 0) in any repository
      ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
          Errno::ECONNREFUSED: Connection refused - Connection refused (http://rubygems.org/latest_specs.4.8.gz)
      

      2/. (Java 6 – Work)

      z:...> jruby -S gem install rake
      Fetching: rake-0.9.2.2.gem (100%)
      Successfully installed rake-0.9.2.2
      1 gem installed
      

      I've only tested this with the two 32-bit Java versions. It bothers me extremely that the same JRUBY version fails with one Java (minor) version upgrade. Recalling that Java 7 is only, Java 1.7.1

        Activity

        Hiro Asari added a comment -

        I wouldn't call Java 7 a minor upgrade, but if the problem is real, then this merits serious investigation regardless.

        However, my custom-built Java 7 (on Mac OS X) has no problem connecting to rubygems.org. I wonder if Java 7 on Windows has a problem.

        $ jruby -v -S gem list -r rake | head
        jruby 1.7.0.dev (ruby-1.8.7-p330) (2011-11-02 18bdfe8) (OpenJDK 64-Bit Server VM 1.7.0-internal) [darwin-x86_64-java]
        rake (0.9.2.2)
        rake-builder (0.0.14)
        rake-command-completion (0.0.1)
        rake-compiler (0.7.9)
        rake-convert (0.0.4)
        rake-debian-build (1.0.18)
        rake-deploy (0.3)
        rake-dir (0.0.1)
        rake-dotnet (0.1.20)
        
        will mason added a comment -

        Hi all.

        Good news! I installed jruby v1.6.5 and the gems work ok with the web. I also checked the 64-bit version.

        -------

        z:> jruby --version
        jruby 1.6.5 (ruby-1.8.7-p330) (2011-10-25 9dcd388) (Java HotSpot(TM) Client VM 1.7.0_01) [Windows 7-x86-java]
        z:> jruby -S gem install rake
        Fetching: rake-0.9.2.2.gem (100%)
        Successfully installed rake-0.9.2.2
        1 gem installed
        z:> set JAVA_HOME=b:\lang\java\jre\x64\v1.7\u01
        z:...> jruby --version
        jruby 1.6.5 (ruby-1.8.7-p330) (2011-10-25 9dcd388) (Java HotSpot(TM) 64-Bit Server VM 1.7.0_01) [Windows 7-amd64-java]
        z:...> jruby -S gem install rake
        Successfully installed rake-0.9.2.2
        1 gem installed

        will mason added a comment -

        I tested Java 7 32-bit and 64-bit on Windows with v1.6.5 – Works well now.

        If you get this problem update.


          People

          • Assignee:
            Unassigned
            Reporter:
            will mason
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: