Details

    • Type: Improvement Improvement
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Ruby 1.9.3
    • Labels:
      None
    • Number of attachments :
      0

      Description

      1.9.3p0 is out. We should update the 1.9 Standard Library to this version.

      http://www.ruby-forum.com/topic/2898015

        Activity

        Hide
        Hiro Asari added a comment -

        Charlie executed this on the master branch. 3b60780

        I don't know if it should be cherry-picked to the 1.6 branch for 1.6.6.

        I'm resolving this for now.

        Show
        Hiro Asari added a comment - Charlie executed this on the master branch. 3b60780 I don't know if it should be cherry-picked to the 1.6 branch for 1.6.6. I'm resolving this for now.
        Hide
        Charles Oliver Nutter added a comment -

        I don't think so. Swapping out the entire stdlib for 1.9.3 would be, in my opinion, too big a change for 1.6.x. If there's specific fixes we should backport, we can do that...but the full 1.9.3 move will be for JRuby 1.7.

        Show
        Charles Oliver Nutter added a comment - I don't think so. Swapping out the entire stdlib for 1.9.3 would be, in my opinion, too big a change for 1.6.x. If there's specific fixes we should backport, we can do that...but the full 1.9.3 move will be for JRuby 1.7.

          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Hiro Asari
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: