JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6115

swing thread exit forces jruby app to exit close despite outstanding jruby threads

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      jruby 1.7.0.dev (ruby-1.8.7-p330) (2011-10-05 a4c297e) (Java HotSpot(TM) Client VM 1.6.0_24) [Windows 7-x86-java]
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      https://gist.github.com/1267992

      see the summary. If the swing thread ever terminates, it appears to kill the JVM, despite outstanding (still running) jruby threads. Appears to anyway.

        Activity

        Roger Pack added a comment -

        appears to becaused by setDefaultOperation CLOSE_ON_EXIT but is this expected/unavoidable? terminate the jruby main thread?

        Charles Oliver Nutter added a comment -

        The Swing behavior for CLOSE_ON_EXIT apparently shuts down the JVM with a hard exit. We can't do much to prevent that.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Roger Pack
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: