Details

    • Type: Improvement Improvement
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6.5
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Miscellaneous
    • Labels:
      None
    • Environment:
      jruby-1_6 branch from github
      OSX Lion
      Apple JDK
    • Number of attachments :
      0

      Description

      When attempting to `ant dist` from the jruby-1_6 branch (or master):

      dist-jar-complete:
           [move] Moving 1 file to /Users/bob/repos/jruby/dist
      
      dist:
           [echo] Running rake gem
           [echo] compile=OFF, threshold=20, objectspace=true threadpool=false reflection=false
           [java] (in /Users/bob/repos/jruby)
           [java] /Users/bob/repos/jruby/bin/jruby -S maybe_install_gems hoe
           [java] /Users/bob/repos/jruby/bin/jruby -S rake package
           [java] Successfully installed hoe-2.12.3
           [java] 1 gem installed
           [java] Generating ast.bat
           [java] Generating autospec.bat
           [java] Generating htmldiff.bat
           [java] Generating install_doc.bat
           [java] Generating jgem.bat
           [java] Generating jrubyc.bat
           [java] Generating ldiff.bat
           [java] Generating rspec.bat
           [java] Generating testrb.bat
           [java] rake aborted!
           [java] uninitialized constant Hoe::Publish::RDoc
           [java] /Users/bob/repos/jruby/gem/Rakefile:58:in `(root)'
           [java] (See full trace by running task with --trace)
           [java] rake aborted!
           [java] Command failed with status (1): [/Users/bob/repos/jruby/bin/jruby -S rake p...]
           [java] 
           [java] (See full trace by running task with --trace)
           [java] (in /Users/bob/repos/jruby/gem)
           [java] #<Gem::LoadError: Could not find rdoc (>= 0) amongst [diff-lcs-1.1.2, hoe-2.12.3, rake-0.8.7, rspec-2.4.0, rspec-core-2.4.0, rspec-expectations-2.4.0, rspec-mocks-2.4.0, sources-0.0.1]>
      

      Adding a maybe_install_gem invocation for rdoc in gem.rake seems to allow the build to complete.

      This commit does that:

      https://github.com/bobmcwhirter/jruby/commit/c43a50e6bde2ca8ed4d585a4764f88878e8d2450

      It may be pulled from a branch on my fork:

      https://github.com/bobmcwhirter/jruby/tree/maybe_install_rdoc

        Activity

        Hiro Asari added a comment -

        Bob,

        I think this is a duplicate of JRUBY-6075.

        Hiro Asari added a comment -

        We started including rdoc recently.


          People

          • Assignee:
            Hiro Asari
            Reporter:
            bob mcwhirter
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: