JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-6077

Allow loading a Ruby source file from the class path using the fully qualified name

    Details

    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      Hi!

      When a JAR is in class path, it would be great to be abe to load files from it using the fully qualified name of the file, including the path to the jar. Currently this is how ActiveSupport dependencies are loaded, and it would be great to able to autoload Ruby source from a JAR.

      I have got it working on master with 3 lines of code side it was mostly working already.

      Pull request:

      https://github.com/jruby/jruby/pull/79

      I hope this can be accepted into JRuby.

        Activity

        Uwe Kubosch added a comment -

        Separate pull request for the jruby-1_6 branch:

        https://github.com/jruby/jruby/pull/80

        Uwe Kubosch added a comment -

        Here is a better pull request, from a topic branch:

        https://github.com/jruby/jruby/pull/83

        Could you look at it?

        Yoko Harada added a comment -

        The patch didn't harm "ant test". (ant spec never passes since before this patch is applied. I gave up)

        The change was applied in rev. afab7b1 on jruby-1_6 and 9134a85 on master branches.
        Would you try and confirm the bug has been gone?

        Uwe Kubosch added a comment -

        I will test it and confirm.

        Uwe Kubosch added a comment -

        Hmm, found an error. I will look at it and report back.

        Uwe Kubosch added a comment -

        No, everything is OK. Confirmed by test.

        Uwe Kubosch made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Uwe Kubosch added a comment -

        Added patch here for easy access.

        Uwe Kubosch made changes -
        Charles Oliver Nutter made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Uwe Kubosch
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: