Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: JRuby 1.7.0.pre1
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Miscellaneous
    • Labels:
      None
    • Environment:
      Mac OSX 10.6.8, Ruby 1.9.3 preview 1, gem 1.8.10, rake 0.9.2.1,
    • Number of attachments :
      0

      Description

      When drying to run the ant dist build task, there is a failure for the spec task. This is how I'm running the build task:

      ant -Djruby.default.ruby.version=1.9 dist

      The following error is displayed:

           [echo] Running rake install_dist_gems
           [echo] compile=OFF, threshold=20, objectspace=true threadpool=false reflection=false
           [java] (in /Users/chriswhite/github/jruby)
           [java] rake aborted!
      ------------------------------------------------------------------------
           [java] undefined method `full_gem_path' for nil:NilClass
           [java] /Users/chriswhite/github/jruby/rakelib/spec.rake:157:in `(root)'
      ------------------------------------------------------------------------
           [java] /Users/chriswhite/github/jruby/lib/ruby/1.9/rake.rb:1874:in `in_namespace'
           [java] /Users/chriswhite/github/jruby/lib/ruby/1.9/rake.rb:908:in `namespace'
           [java] /Users/chriswhite/github/jruby/rakelib/spec.rake:16:in `(root)'
           [java] org/jruby/RubyKernel.java:996:in `load'
           [java] /Users/chriswhite/github/jruby/rakelib/spec.rake:1612:in `load'
           [java] /Users/chriswhite/github/jruby/lib/ruby/1.9/rake.rb:2430:in `load_imports'
           [java] /Users/chriswhite/github/jruby/lib/ruby/1.9/rake.rb:2380:in `raw_load_rakefile'
           [java] /Users/chriswhite/github/jruby/lib/ruby/1.9/rake.rb:2007:in `load_rakefile'
           [java] /Users/chriswhite/github/jruby/lib/ruby/1.9/rake.rb:2058:in `standard_exception_handling'
           [java] /Users/chriswhite/github/jruby/lib/ruby/1.9/rake.rb:2006:in `load_rakefile'
           [java] /Users/chriswhite/github/jruby/lib/ruby/1.9/rake.rb:1991:in `run'
           [java] /Users/chriswhite/Ruby/ruby-1.9.3/bin/rake:32:in `(root)'
      

      The particular line indicated by spec.rake:157 is:

      rake_location = File.join(Gem.loaded_specs['rake'].full_gem_path, "lib")
      

      A quick look at an irb session shows that Gem.loaded_specs is an empty hash, which would explain the issue. Unfortunately I'm not yet able to pinpoint why it's empty.

        Activity

        Hiro Asari added a comment -

        Why are you using the 1.9 mode in the dist target? I'm not sure if it gives you anything special.

        Also, we've had problems with the dist target recently, so this could very well be a variation of that problem.

        As of this writing (b9d59b0), the above command succeeds on my machine: https://gist.github.com/1226000

        Please try again. If confirmed, I'll resolve this as "Fixed".

        Chris White added a comment -

        The build was set to 1.9 mode so it would be enabled by default upon running the jruby command line executable. This is mainly due to the fact that I do a lot more 1.9 work. As a test I ran the build as just `ant build && ant dist` and didn't get this error, but another error instead ( https://gist.github.com/1226019 ). However since the error is in an unrelated location this should probably be reported as a separate bug if it doesn't exist. Unfortunately I'm about to head to sleep so I don't have the time to check up on that at the moment.

        Hiro Asari added a comment -

        I'm going to mark this as "Not a Bug" in the absence of more evidence.


          People

          • Assignee:
            Hiro Asari
            Reporter:
            Chris White
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: