JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-5896

Could not initialize class com.kenai.jaffl.struct.Struct$Constants

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6RC3
    • Fix Version/s: JRuby 1.6.4
    • Component/s: None
    • Labels:
    • Environment:
      Windows, Turkish language
    • Number of attachments :
      0

      Description

      We have users of Aptana Studio experiencing problems with ruby code being executed with the bundled JRuby. The logs show:
      An error occurred while executing /home/user/Programs/Aptana Studio 3/configuration/org.eclipse.osgi/bundles/564/1/.cp/bundles/ruby.ruble/commands/insert_erb_tags.rb: java.lang.NoClassDefFoundError: Could not initialize class com.kenai.jaffl.struct.Struct$Constants

      "It seems that at least three other people have experienced this problem and their names imply that they are all Turkish (like me), so we can assume each one of us have something in common, and that might be the "Regional Settings" of the OS. For example, In regional settings of Turkish language the decimal symbol is "," and not "." This is the most common cause of errors related to internationalization in our language. Another common error is encountered while using String functions like "toUpper" or "toLower", because "i".toUpper() is not "I" in Turkish. Here is a good article related to internationalization problems in Turkish.

      I don't mean to be rude or smartass; the real problem might have nothing to do with these issues, however these are all the possible causes I can think of.

      Hope these help. I love Aptana and I want my rubles back "

      "I've uninstalled Aptana, changed OS's regional settings to English (United States), installed the latest release of Aptana again, launched it, and everything works fine. No exceptions. So, it is definitely an internationalization issue. You can just switch yours to Turkish in order to reproduce the bug."

      Here's the original bug report for Aptana: http://jira.appcelerator.org/browse/APSTUD-2266

      It appears the bug cropped up when I upgraded the bundled JRuby from 1.6RC1 to 1.6RC3. We now use 1.6.2, and I'm not sure if that version fixes the issue.

        Activity

        Christopher Williams added a comment -

        I still have users experiencing this against our latest release which is using 1.6.3, and it's a blocker for our scripting functionality.

        Charles Oliver Nutter added a comment -

        This should be fixed. I can force an early load of Struct, which should help it. I thought for sure we'd patched this in 1.6.x.

        Charles Oliver Nutter added a comment -

        Should be fixed with an update of jnr-ffi in jruby-1_6@ec6f841


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Christopher Williams
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: