Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Ruby 1.9.2
    • Labels:
      None
    • Environment:
      jruby 1.6.1 (ruby-1.8.7-p330) (2011-05-19 18a2624) (Java HotSpot(TM) Client VM 1.6.0_24) [Windows 7-x86-java]
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      $ j --1.9 -S irb 2>&1| head
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:22 warning: already initialized constant ALPHA
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:24 warning: already initialized constant ALNUM
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:28 warning: already initialized constant HEX
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:30 warning: already initialized constant ESCAPED
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:34 warning: already initialized constant UNRESERVED
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:39 warning: already initialized constant RESERVED
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:42 warning: already initialized constant DOMLABEL
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:44 warning: already initialized constant TOPLABEL
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:46 warning: already initialized constant HOSTNAME
      G:/dev_d/ruby/downloads/jruby/lib/ruby/1.9/uri/common.rb:428 warning: already initialized constant DEFAULT_PARSER
      ...
      and if I do another
      >> require 'rubygems'
      within irb, it seems to double load rubygems for some reason.

        Activity

        Roger Pack added a comment -

        Also related I think:

        https://github.com/trinidad/trinidad/issues/11

        Also in general 1.9 mode seems broken

        running a separate app:
        ...
        G:/dev_d/ruby/downloads/jruby/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:349 warning: already initialized constant Cache
        LoadError: library `java' could not be loaded: java.lang.StackOverflowError

        Roger Pack added a comment -

        And another I believe related. Sorry if this is a dupe.

        ...
        G:/dev_d/ruby/downloads/jruby/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:349 warning: already initialized constant Cache
        JavaUtil.java:165:in `convertJavaToUsableRubyObject': java.lang.NoClassDefFoundError: Could not initialize class org.jruby.javasupport.Java
        from RuntimeHelpers.java:1033:in `checkJavaException'
        from RuntimeHelpers.java:1057:in `isJavaExceptionHandled'
        from RescueNode.java:197:in `handleJavaException'
        from RescueNode.java:141:in `interpretWithJavaExceptions'
        from RescueNode.java:110:in `interpret'
        from ASTInterpreter.java:75:in `INTERPRET_METHOD'
        from InterpretedMethod.java:190:in `call'
        from DefaultMethod.java:179:in `call'
        from CachingCallSite.java:282:in `cacheAndCall'
        from CachingCallSite.java:139:in `call'
        from bin\screen_saver:5:in `_file_'
        from bin\screen_saver:-1:in `load'
        from Ruby.java:686:in `runScript'
        from Ruby.java:590:in `runNormally'
        from Ruby.java:439:in `runFromMain'
        from Main.java:278:in `doRunFromMain'
        from Main.java:198:in `internalRun'
        from Main.java:164:in `run'
        from Main.java:148:in `run'
        from Main.java:128:in `main'

        Hiroshi Nakamura added a comment -

        Confirmed that I can reproduce it on Windows. I should have broken require on Windows...

        I'll investigate it.

        Hiroshi Nakamura added a comment -

        Sorry, it's my fault.

        commit a94f4da9cb6068260ff53d977365e99020873781
        Author: Hiroshi Nakamura <nahi@ruby-lang.org>
        Date:   Fri May 20 11:45:55 2011 +0900
        
            JRUBY-5811: should check $" in lower case on case insensitive FS
            
            Conflict resolution at d54bb64ee61fb46b3ed2836f76c25dc9d9ce1a2d did not
            honor case sensitivity flag in StringArraySet.
        

          People

          • Assignee:
            Hiroshi Nakamura
            Reporter:
            Roger Pack
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: