Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6
    • Fix Version/s: JRuby 1.6.1
    • Component/s: Miscellaneous
    • Labels:
      None
    • Environment:
      Solaris 10/x86
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      I get the error below when running the 'ant dist-bin' target. Attached is a patch to reorder the gems such that they get installed so that the dependencies are met.

      install-dev-gems:
      [java] Removing rake
      [java] ERROR: While executing gem ... (Gem::InstallError)
      [java] cannot uninstall, check `gem list -d rspec-core`
      [java] Successfully uninstalled rake-0.8.7
      [java] Java Result: 1
      [java] Successfully installed rake-0.8.7
      [java] **************************************************
      [java]
      [java] Thank you for installing rspec-core-2.4.0
      [java]
      [java] Please be sure to look at the upgrade instructions to see what might have
      [java] changed since the last release:
      [java]
      [java] http://github.com/rspec/rspec-core/blob/master/Upgrade.markdown
      [java]
      [java] **************************************************
      [java] Successfully installed rspec-core-2.4.0
      [java] ERROR: Error installing build_lib/rspec-expectations-2.4.0.gem:
      [java] rspec-expectations requires diff-lcs (~> 1.1.2, runtime)
      [java] Successfully installed rspec-mocks-2.4.0
      [java] Successfully installed diff-lcs-1.1.2
      [java] 4 gems installed
      [java] ERROR: Error installing build_lib/rspec-2.4.0.gem:
      [java] rspec requires rspec-expectations (~> 2.4.0, runtime)

      BUILD FAILED
      /sw/src/BUILD/jruby-1.6.0/build.xml:789: Java returned: 1

      Total time: 1 minute 10 seconds
      error: Bad exit status from /var/tmp/rpm-tmp.VUaWw4 (%build)

        Activity

        Hide
        Charles Oliver Nutter added a comment -

        Hmm, we must be specifying no-dependencies to ensure we're only installing the versions we want. Change seems fine.

        commit be823d88d2adbd01fa69c4cf2c50bfbf605a1b3b
        Author: Charles Oliver Nutter <headius@headius.com>
        Date: Thu Mar 24 18:59:54 2011 -0500

        Fix JRUBY-5599: install-dev-gems target has gems ordered incorrectly

        Show
        Charles Oliver Nutter added a comment - Hmm, we must be specifying no-dependencies to ensure we're only installing the versions we want. Change seems fine. commit be823d88d2adbd01fa69c4cf2c50bfbf605a1b3b Author: Charles Oliver Nutter <headius@headius.com> Date: Thu Mar 24 18:59:54 2011 -0500 Fix JRUBY-5599 : install-dev-gems target has gems ordered incorrectly

          People

          • Assignee:
            Unassigned
            Reporter:
            Clayton O'Neill
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: