Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6RC1
    • Fix Version/s: JRuby 1.6RC2
    • Component/s: Embedding
    • Labels:
      None
    • Number of attachments :
      1

      Description

      I have an application that is deployed via WebStart and uses
      JRuby Complete. It was working properly with jruby-complete-1.5.1.jar
      but with jruby-complete-1.6.0.RC1.jar the standard gems cannot
      be loaded:

      Warning: JRuby home "http:/xx.xxx.xxx.xx:5555/lib/jruby-complete-1.6.0.RC1.jar!/META-INF/jruby.home" does not exist, using C:\DOCUME~1\xxx~1\LOCALS~1\Temp\
      null:-1:in `getStackTrace': no such file to load – date (LoadError)
      from RubyException.java:154:in `prepareBacktrace'
      from RaiseException.java:156:in `preRaise'
      from Ruby.java:3432:in `newRaiseException'
      from Ruby.java:3325:in `newLoadError'
      from LoadService.java:657:in `trySearch'
      from LoadService.java:283:in `findFileForLoad'
      from LoadService.java:330:in `smartLoad'
      from LoadService.java:379:in `require'
      from LoadService.java:304:in `lockAndRequire'
      from RubyKernel.java:1058:in `requireCommon'
      from RubyKernel.java:1041:in `require'
      from org/jruby/RubyKernel$s_method_1_0$RUBYINVOKER$require.gen:65535:in `call'
      from JavaMethod.java:319:in `call'
      from CachingCallSite.java:282:in `cacheAndCall'
      from CachingCallSite.java:139:in `call'
      from FCallOneArgNode.java:36:in `interpret'
      from NewlineNode.java:103:in `interpret'
      from BlockNode.java:71:in `interpret'
      from RootNode.java:129:in `interpret'
      from ASTInterpreter.java:115:in `INTERPRET_ROOT'
      from Ruby.java:729:in `runInterpreter'
      from Ruby.java:2609:in `loadFile'
      from ExternalScript.java:66:in `load'
      from LoadService.java:748:in `tryLoadingLibraryOrScript'
      from LoadService.java:332:in `smartLoad'
      from LoadService.java:379:in `require'
      from LoadService.java:304:in `lockAndRequire'
      from RubyKernel.java:1058:in `requireCommon'
      from RubyKernel.java:1041:in `require'
      from org/jruby/RubyKernel$s_method_1_0$RUBYINVOKER$require.gen:65535:in `call'
      from JavaMethod.java:319:in `call'
      from CachingCallSite.java:282:in `cacheAndCall'
      from CachingCallSite.java:139:in `call'
      from FCallOneArgNode.java:36:in `interpret'
      from NewlineNode.java:103:in `interpret'
      from RootNode.java:129:in `interpret'
      from ASTInterpreter.java:115:in `INTERPRET_ROOT'
      from Ruby.java:729:in `runInterpreter'
      from Ruby.java:737:in `runInterpreter'
      from EmbedEvalUnitImpl.java:119:in `run'
      from ScriptingContainer.java:1222:in `runUnit'
      from ScriptingContainer.java:1215:in `runScriptlet'

      I had the same issues prior 1.5 where headius did some fix for me - might be the same
      problem again?

        Activity

        lucas dicioccio added a comment -

        I think, the problem is similar to the one I've identified at:
        http://jira.codehaus.org/browse/JRUBY-5345

        Alex K added a comment -

        Tried it with the lastest stable from Feb 4th(includes the fix for #5345) but with the same result - same error...

        David Calavera added a comment -

        I have a question about this bug, sorry but I never used WebStart

        is the single slash after the http protocol right? "http:/xx.xxx.xxx.xx:5555/" That url doesn't seem right to me

        Alex K added a comment -

        Yeah, you are completely right. Just checked it twice and the slash is really missing. This might be the reason for the error - but I am not quite sure... The problem now is, that I cannot change the path as this is done automatically by jruby;(

        Charles Oliver Nutter added a comment -

        Is it possible for you to submit a webstart app we can attempt to build and run ourselves?

        Alex K added a comment -

        Test application

        Alex K added a comment -

        I removed the jruby .jar to get a smaller footprint. But you need to change the .jnlp $$codebase entry with you http server adress (you need to test it over a web server because local execution works already).

        Alex K added a comment -

        Tested it with RC2 and now it works again.


          People

          • Assignee:
            Unassigned
            Reporter:
            Alex K
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: