Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: JRuby 1.5.6
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
    • Number of attachments :
      0

      Description

      Hi. I have successfully updated rubygems to version 1.5.0 on all my rubies except for JRuby.

      $ rvm list
      rvm rubies
      ruby-1.9.2-p136 [ x86_64 ]
      rbx-1.2.0-20101221 [ ]
      ree-1.8.7-2010.02 [ x86_64 ]
      ruby-1.8.7-p330 [ x86_64 ]
      => jruby-1.5.6 [ amd64-java ]
      Here is the transcript:

      $ ruby -v
      jruby 1.5.6 (ruby 1.8.7 patchlevel 249) (2010-12-03 9cf97c3) (Java HotSpot(TM) 64-Bit Server VM 1.6.0_17) [amd64-java]
      $ gem -v
      1.3.6
      $ gem update --system
      Updating RubyGems
      Updating rubygems-update
      Successfully installed rubygems-update-1.5.0
      Updating RubyGems to 1.5.0
      Installing RubyGems 1.5.0
      ~/.rvm/gems/jruby-1.5.6/gems/rubygems-update-1.5.0/lib/rubygems/gem_runner.rb:84: undefined method `load_plugins' for Gem:Module (NoMethodError)
      from ~/.rvm/gems/jruby-1.5.6/gems/rubygems-update-1.5.0/lib/rubygems/gem_runner.rb:31:in `require'
      from ~/.rvm/rubies/jruby-1.5.6/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
      from setup.rb:25
      RubyGems system software updated
      $ gem -v
      1.3.6
      I have also tried gem install rubygem-update; update_rubygems and ruby setup.rb variants, to the exactly same effect.

      ------------------------------------------------------------------------------------------

      $ gem list

          • LOCAL GEMS ***

      activesupport (2.3.10)
      bouncy-castle-java (1.5.0145.2)
      brown_shoes (0.0.0)
      cartesian (0.6.0)
      facets (2.9.0)
      hoe (2.8.0)
      jruby-launcher (1.0.5, 1.0.3)
      jruby-openssl (0.7.3, 0.7.2)
      newgem (1.5.3)
      rake (0.8.7)
      RedCloth (4.2.3)
      rubigen (1.5.5)
      rubygems-update (1.5.0)
      syntax (1.0.0)

      ------------------------------------------------------------------------------------------

      First reported on RubyGems and filed here by suggestion of Charles Nutter (http://help.rubygems.org/discussions/problems/479-failure-updating-to-rubygems-150-on-jruby-156).

        Activity

        Hide
        Nick Howard added a comment -

        When I upgraded RubyGems to 1.5.0, it worked for me. I'm guessing it's because I'd upgraded before to 1.4.2. You could try installing rubygems-update -v 1.4.2 and upgrading to that and then updating to 1.5.0 from there.

        Show
        Nick Howard added a comment - When I upgraded RubyGems to 1.5.0, it worked for me. I'm guessing it's because I'd upgraded before to 1.4.2. You could try installing rubygems-update -v 1.4.2 and upgrading to that and then updating to 1.5.0 from there.
        Hide
        Adriano Mitre added a comment - - edited

        Nope. Tried upgrading to 1.4.2 and to 1.3.7, with no better luck.

        ~$ rm rf ~/.rvm/gems/jruby-1.5.6/gems/rubygems-update*
        ~$ gem query --local -d -n rubygems-update

            • LOCAL GEMS ***

        ~$ gem install rubygems-update -v 1.4.2
        Successfully installed rubygems-update-1.4.2
        1 gem installed
        ~$ update_rubygems
        /home/adriano/.rvm/gems/jruby-1.5.6/gems/rubygems-update-1.4.2/lib/rubygems/gem_runner.rb:14: undefined method `load_env_plugins' for Gem:Module (NoMethodError)
        from /home/adriano/.rvm/gems/jruby-1.5.6/gems/rubygems-update-1.4.2/lib/rubygems/gem_runner.rb:31:in `require'
        from /home/adriano/.rvm/rubies/jruby-1.5.6/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from setup.rb:25
        ~$ gem -v 1.3.6

        Show
        Adriano Mitre added a comment - - edited Nope. Tried upgrading to 1.4.2 and to 1.3.7, with no better luck. ~$ rm rf ~/.rvm/gems/jruby-1.5.6/gems/rubygems-update * ~$ gem query --local -d -n rubygems-update LOCAL GEMS *** ~$ gem install rubygems-update -v 1.4.2 Successfully installed rubygems-update-1.4.2 1 gem installed ~$ update_rubygems /home/adriano/.rvm/gems/jruby-1.5.6/gems/rubygems-update-1.4.2/lib/rubygems/gem_runner.rb:14: undefined method `load_env_plugins' for Gem:Module (NoMethodError) from /home/adriano/.rvm/gems/jruby-1.5.6/gems/rubygems-update-1.4.2/lib/rubygems/gem_runner.rb:31:in `require' from /home/adriano/.rvm/rubies/jruby-1.5.6/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require' from setup.rb:25 ~$ gem -v 1.3.6
        Hide
        Daniel Harrington added a comment - - edited

        same problem here. don't know how i could help, but i'll try to find a way.
        installed jruby 1.5.6 through rvm. i'm running os x 10.6.6

        Show
        Daniel Harrington added a comment - - edited same problem here. don't know how i could help, but i'll try to find a way. installed jruby 1.5.6 through rvm. i'm running os x 10.6.6
        Hide
        Anna Gabutero added a comment - - edited

        I ran into this problem and eventually figured out my RUBYOPT=-rubygems environment variable was the culprit. After I unset it I was able to upgrade.

        Show
        Anna Gabutero added a comment - - edited I ran into this problem and eventually figured out my RUBYOPT=-rubygems environment variable was the culprit. After I unset it I was able to upgrade.
        Hide
        Adriano Mitre added a comment -

        Anna's solution worked for me as well:

        RUBYOPT= ; jruby -S gem update --system

        Show
        Adriano Mitre added a comment - Anna's solution worked for me as well: RUBYOPT= ; jruby -S gem update --system
        Hide
        Charles Oliver Nutter added a comment -

        Ahh, so in your cases, I'm guessing RUBYOPT was set to something like "-rubygems" and as a result RubyGems loaded at an inopportune moment.

        I think we're going to close this WONTFIX, since the workaround is simple and I'm pretty sure we're not doing anything special (though I recognize we were the only one that didn't upgrade properly).

        In the future, system upgrade of RubyGems may be contraindicated for JRuby, since we have included some modifications. We'll cross that bridge when we come to it.

        Show
        Charles Oliver Nutter added a comment - Ahh, so in your cases, I'm guessing RUBYOPT was set to something like "-rubygems" and as a result RubyGems loaded at an inopportune moment. I think we're going to close this WONTFIX, since the workaround is simple and I'm pretty sure we're not doing anything special (though I recognize we were the only one that didn't upgrade properly). In the future, system upgrade of RubyGems may be contraindicated for JRuby, since we have included some modifications. We'll cross that bridge when we come to it.

          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            Adriano Mitre
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: