Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: JRuby 1.6RC1
    • Fix Version/s: None
    • Component/s: Core Classes/Modules
    • Labels:
      None
    • Environment:
      Windows 7 x64, Windows XP 32-bit
    • Testcase included:
      yes
    • Number of attachments :
      1

      Description

      In JRuby 1.6.0 RC1, file and directory operations do not work when dealing with the root directory of a UNC network share. (Verified on Windows XP 32-bit and Windows 7 x64).

      Example:
      require 'FileUtils'
      Dir.entries("//fileshare/rootfolder")
      File.directory?("//engfile6/pa")

      ...both statements throw: Errno::ENOENT: No such file or directory - //fileshare/rootfolder.

      Copying and moving files/folders also results in similar problems. This only happens on the root share directory. For example, Dir.entries("//fileshare/rootfolder/work") works as expected.

      I've verified that these problems are not present in MRI Ruby 1.9.2, so this seems to be specific to JRuby. I'm running JRuby IRB with the --1.9 flag.

      Apologies if this is a duplicate issue. I saw several UNC-related issues, but none seemed to address this specific one. Please let me know if you need any additional information. Thanks.

        Issue Links

          Activity

          Hiro Asari made changes -
          Field Original Value New Value
          Link This issue duplicates JRUBY-2724 [ JRUBY-2724 ]
          Hiro Asari added a comment -

          This sounds like a duplicate of this old issue.

          Hiro Asari added a comment -

          I'm resolving this as duplicate, but if you believe it's a new problem, please reopen it.

          Hiro Asari made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          David Escobar added a comment -

          It certainly seems to be the same (or very similar) issue. 2724 was originally filed back in 2008. Is this fix scheduled to make it into the final version of 1.6? If it's not, then it may be a good idea to reopen the issue for visibility, as this is a blocking issue in many applications.

          David Escobar added a comment -

          I'm reopening this issue because none of the related and duplicate issues on this matter have been addressed (that I can tell, anyway). Some go as far back as 2008. Since Windows compatibility is stated as a major goal of JRuby 1.6, this issue should be addressed, as accessing UNC network drives is a major part of many programs running on Windows.

          David Escobar made changes -
          Resolution Duplicate [ 3 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Hiro Asari added a comment -

          David,

          I've noted in JRUBY-2774 that the problem persists in 1.6.0.RC1. This ticket adds nothing new to that ticket. Please add your additional comments there.

          Thanks.

          Hiro Asari made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Charles Oliver Nutter made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              David Escobar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: