Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.6RC1
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Java Integration
    • Labels:
      None
    • Environment:
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      This bug blocks the tests I would like to implement for JRUBY-5345 (we might need to reopen once we have a reliable test suite for this case).

      When creating a directory with an "hi" (UTF-8 e-accute-accent) from within a Jar, will instead create a directory called "hi%89" (URL Encoded version of MacRoman e-accute-accent).
      To prevent any source-file encoding issue, I manually pack the "" accent from its binary representation with [0xc3, 0xa9].pack('C*') and I freeze the string.

      In https://github.com/lucasdicioccio/jruby/commits/accents

      I've modified test_jar_complete.rb:

      • added a test case for jar run from paths with accents (JRUBY-5345)
      • adding an assertion on the content of the test directory content (this bug report)

      I've also added a similar test in test_jruby_dirnames.rb . It executes without failure/errors with ./bin/jruby from the same build. Thus I think the issue is JAR-related.

        Activity

        Hiro Asari added a comment -

        Hi, Lucas,

        I apologize for not reviewing this sooner.

        It sounds like you had a patch, but it's been deleted. Do you still have it?

        lucas dicioccio added a comment -

        Hi,
        Since the bug has been fixed, I think I'm affraid I've deleted the branch. Now that I think about it, along with my temptatives to fix the bug, I had a test case that was worth saving (the only thing I did was adding a directory with a weird file name to the jar test in test/test_jar_complete.rb : I built the string for the path with accent using ['c3','a9'].pack('H2H2') (for '':utf8)).
        I'll look if I have a backup in one of my test VMs, but I guess I won't.

        Charles Oliver Nutter added a comment -

        We'll call this fixed. It's very likely that we picked up some Dir tests that deal with unicode since then, and even if not...this isn't a blocker and isn't broken anymore.


          People

          • Assignee:
            Charles Oliver Nutter
            Reporter:
            lucas dicioccio
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: