Details

    • Type: Bug Bug
    • Status: Reopened Reopened
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Windows
    • Labels:
      None
    • Environment:
      jruby 1.5.0.dev (ruby 1.8.7 patchlevel 174) (2010-01-14 34d9c5f) (Java HotSpot(TM) Client VM 1.6.0_17) [x86-java]
    • Number of attachments :
      0

      Description

      E:\dev\ruby\old\faster_require>ls -l
      total 26
      rw-rr- 1 packrd Administ 1137 Jan 27 21:22 README
      rw-rr- 1 packrd Administ 519 Jan 29 21:12 Rakefile
      rw-rr- 1 packrd Administ 7 Jan 29 21:18 VERSION
      drwxr-xr-x 2 packrd Administ 0 Jan 29 21:13 bin
      rw-rr- 1 packrd Administ 9216 Jan 29 22:37 faster_require-0.5.0.gem
      rw-rr- 1 packrd Administ 2889 Jan 29 22:37 faster_require.gemspec
      drwxr-xr-x 2 packrd Administ 0 Jan 29 22:35 lib
      rw-rr- 1 packrd Administ 36032 Jan 20 23:57 out
      drwxr-xr-x 2 packrd Administ 0 Jan 27 20:28 pkg
      drwxr-xr-x 3 packrd Administ 0 Jan 29 22:35 spec

      E:\dev\ruby\old\faster_require>gem install *.gem --local
      JRuby limited openssl loaded. http://jruby.org/openssl
      gem install jruby-openssl for full support.

      Successfully installed faster_require-0.5.0
      ERROR: could not find gem faster_require.gemspec locally or in a repository
      1 gem installed

      (with MRI, that ERROR line is not there).

      Thanks!
      -r

        Activity

        Hide
        Charles Oliver Nutter added a comment -

        Odd...can you try to narrow this down to a simple .rb script that shows the command-line globs are acting oddly? Doing it via the "gem" command means we have to walk a lot of code to see what's actually happening.

        Show
        Charles Oliver Nutter added a comment - Odd...can you try to narrow this down to a simple .rb script that shows the command-line globs are acting oddly? Doing it via the "gem" command means we have to walk a lot of code to see what's actually happening.
        Hide
        Roger Pack added a comment -

        appears that this has been fixed at some point along the line.

        E:\dev\ruby\old\faster_require>gem install *.gem --local
        JRuby limited openssl loaded. http://jruby.org/openssl
        gem install jruby-openssl for full support.
        Successfully installed faster_require-0.5.2
        1 gem installed

        Show
        Roger Pack added a comment - appears that this has been fixed at some point along the line. E:\dev\ruby\old\faster_require>gem install *.gem --local JRuby limited openssl loaded. http://jruby.org/openssl gem install jruby-openssl for full support. Successfully installed faster_require-0.5.2 1 gem installed
        Hide
        Roger Pack added a comment -

        I'm not sure exactly what is going on here...is ruby expanding these for me?

        C:\dev\ruby\faster_rubygems>cat bad.rb
        p ARGV

        C:\dev\ruby\faster_rubygems>jruby -S bad.rb build *.gemspec
        ["build", "*.gemspec"]

        C:\dev\ruby\faster_rubygems>pik 192 # same with 1.8.6

        C:\dev\ruby\faster_rubygems>ruby -S ./bad.rb build *.gemspec
        ["build", "faster_rubygems.gemspec"]

        Show
        Roger Pack added a comment - I'm not sure exactly what is going on here...is ruby expanding these for me? C:\dev\ruby\faster_rubygems>cat bad.rb p ARGV C:\dev\ruby\faster_rubygems>jruby -S bad.rb build *.gemspec ["build", "*.gemspec"] C:\dev\ruby\faster_rubygems>pik 192 # same with 1.8.6 C:\dev\ruby\faster_rubygems>ruby -S ./bad.rb build *.gemspec ["build", "faster_rubygems.gemspec"]
        Show
        Roger Pack added a comment - just was bit by this again http://groups.google.com/group/redcar-editor/browse_thread/thread/2e2daef4e8f6cb98

          People

          • Assignee:
            Unassigned
            Reporter:
            Roger Pack
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: