JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-4249

JRuby's in-process launching magic does not always work on Windows as expected

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.4
    • Fix Version/s: JRuby 1.5
    • Component/s: Windows
    • Labels:
      None
    • Environment:
      latest jruby dev.
    • Number of attachments :
      0

      Description

      Consider the following:

      `ruby -v`

      When launched from JRuby, this is executed in-process. On both, Windows and Linux.

      But,

      `ruby.exe -v` on Windows is not being executed in-process. See JRUBY-4238 for the example of problems, caused by this.
      For consistency, JRuby should handle both ruby and ruby.exe on Windows the same way.

      Will fix.

        Issue Links

          Activity

          Vladimir Sizikov made changes -
          Field Original Value New Value
          Link This issue relates to JRUBY-4238 [ JRUBY-4238 ]
          Vladimir Sizikov made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          Charles Oliver Nutter made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Vladimir Sizikov
              Reporter:
              Vladimir Sizikov
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: