Details

    • Type: Task Task
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.4
    • Fix Version/s: JRuby 1.7.0.pre1
    • Component/s: Core Classes/Modules
    • Labels:
      None
    • Environment:
      Mac OS X 10.6.1
    • Number of attachments :
      0

      Description

      Please reopen JRUBY-3894. The issue is not fixed; ../ in JAR paths still causes problems in 1.4.0.

        Activity

        Hiro Asari added a comment -

        This seems to be fixed on master.

        Yoko Harada added a comment -

        JRUBY-4220 might be caused by the same bug. Like reported in JRUBY-3894, when a script is loaded from a classpath, _FILE_ fails. So, test_file.rb, test_dir.rb, and few more tests fails if those are loaded from the classpath, but passes successfully if those are read from an absolute path.

        Marnen Laibow-Koser added a comment -

        _FILE_ in jar paths seems to be fixed, but .. is not.

        Marnen Laibow-Koser added a comment -

        You wrote:
        > Thanks for the report. I think that opening this new jira issue is more appropriate than reopening older bugs.

        Why? If the bug was not fixed, then the older ticket should not have been closed in the first place.

        > It would be also great if you could provide exact description of what is broken and how to reproduce, esp. with test cases.

        The issue is exactly as described in JRUBY-3894 with regard to the behavior of .. in jar paths.

        Vladimir Sizikov added a comment -

        Thanks for the report. I think that opening this new jira issue is more appropriate than reopening older bugs.

        It would be also great if you could provide exact description of what is broken and how to reproduce, esp. with test cases.

        Thanks!


          People

          • Assignee:
            Unassigned
            Reporter:
            Marnen Laibow-Koser
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: