Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: JRuby 1.3
    • Fix Version/s: JRuby 1.5
    • Component/s: None
    • Labels:
      None
    • Environment:
      Server: JRuby 1.3, Rails 2.3.2, Mongrel (tested with WEBrick, same result)
      Client: Windows CE 5.0, Internet Explorer 6
    • Number of attachments :
      1

      Description

      I set up a Rails-Application that uses a javascript-library. If I access this application on my Windows XP machine with Firefox, everything works fine. But on a handheld device with Windows CE / IE6, the javascript-library was not loaded resp. does not work.

      This is my view:

      <html>
      <head>
      <title>Barcodes</title>
      <%= javascript_include_tag "taffy" %>
      </head>
      <body onLoad="initialize()">
      ...
      </body>
      </html>

      Following information for your attention:

      1. The problem does not occur on MRI 1.8
      2. It doesn't matter if I use <%= javascript_include_tag "taffy" %> or <script src="taffy.js" />
      3. I'm able to download the javascript-lib from /javascripts-folder on my handheld device, but it will not be loaded with my view.
      4. If I copy the content from the libary-file and paste it into <script>...</script>-Tags instead, it will work both on XP/Firefox and CE/IE6

      1. diff.htm
        32 kB
        Stefan Klöckner

        Activity

        Charles Oliver Nutter added a comment -

        What does the generated HTML look like on your CE browser? Does it have the appropriate tags for javascript? Is Rails perhaps thinking that your browser does not support javascript?

        Stefan Klöckner added a comment - - edited

        I picked up the generated HTML source of both browsers (wince/ie6 and winxp/firefox) and generated a diff report (see attached file). Both files look identically. Only blank lines and one <a href="...">-Tag differ in some way, but I think, this doen't matter.

        Since the <%= javascript_include_tag %>-functions are correctly rendered to <script>-Tags, I think, this is not the problem. I introduced <script>-Tags directly into my new.html.erb-File instead of using javascript_include_tag, but to no effect.

        Rails correclty renders <script>-Tags, and deploys all javascripts-files. So I don't think, that rails mistakenly assumes, that my browser doen't support javascript. But I will keep track on it.

        Charles Oliver Nutter added a comment -

        Stefan: Ok...this is a hard one for us to reproduce, since I'm sure none of us have CE devices. Hopefully you'll be able to hunt it down. Perhaps contact Rails folks? This doesn't seem like something that would be JRuby's fault.

        Stefan Klöckner added a comment -

        The problem occurs since I switched from MRI 1.8 to JRuby 1.3. So I thought, this would be a JRuby-Issue. But maybe I'm wrong, so I will contact rails folks next.

        In the meantime I've implemented a workaround, so this is not critical for me anymore.

        Thank you for your time and help!

        Thomas E Enebo added a comment -

        This is getting closed as cannot reproduce. If we do have a problem then I am guessing Stefan will come back with something that is easier for us to reproduce. wince + Rails heh.. cool. So Stefan if you do dig deeper and find a specific jruby issue then just file a new issue with those details.


          People

          • Assignee:
            Thomas E Enebo
            Reporter:
            Stefan Klöckner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: