Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 0.9.2
    • Fix Version/s: None
    • Component/s: Miscellaneous
    • Labels:
      None
    • Environment:
      Gentoo Linux
    • Number of attachments :
      1

      Description

      jruby 0.9.2 seems to have added a new dependency on jline. The problem is that the version, 0.9.91-SNAPSHOT isn't released yet, and 0.9.9 isn't API comptible. I also don't see any mention of jline in the docs, with regard to where it came from, and where the jar came from.

      This is causing me some grief when packaging 0.9.2 for Gentoo, as we don't use bundled jars, instead we use jars we've already packaged.

        Activity

        Damian Steer added a comment -

        The jar used is (or rather was) jline cvs head, with http://sourceforge.net/tracker/index.php?func=detail&aid=1596683&group_id=64033&atid=506056 applied.

        I'll prod Marc from jline to see when he's going to do a release. The are (iirc) just two method differences, so you could probably patch jruby simply.

        Damian Steer added a comment -

        Apparently the next release is due in about a month (waiting for a windows patch, apparently). I'll resolve this issue when we're in sync then.

        Let me know if this is ok. I can point you at the method calls that need patching if you want to try that in the meantime.

        Joshua Nichols added a comment -

        If I could get a patch to use the old method signatures, or at least at least point me in the right direction, that'd be great.

        Damian Steer added a comment -

        You just need to remove / comment out the following from src/org/jruby/ext/Readline.java:

        readline.setUsePagination(true);
        ((CandidateListCompletionHandler) readline.getCompletionHandler()).setAlwaysIncludeNewline(false);
        

        (lines 88 and 89)

        The result won't be quite the same as the snapshot (I contributed some improvements, and presumably there are other fixes) but it seems to work.

        Joshua Nichols added a comment -

        This still seems to be an issue with 0.9.8, and there isn't a sign of a 0.9.91 release of jline yet.

        Damian Steer added a comment -

        Jline 0.9.91 has been released, with our fixes. We should be able to resolve this now.

        http://jline.sourceforge.net/m2repo/jline/jline/0.9.91/

        Damian Steer added a comment -

        Quick patch to fix references to jline-0.9.91-SNAPSHOT.jar. Hopefully this will work for maven when MAVENUPLOAD-1414 is resolved (i.e. jline 0.9.91 is in maven repositories).

        Charles Oliver Nutter added a comment -

        Closing resolved issues that were never attached to a release (mostly invalid, wontfix, dupes, or incomplete).


          People

          • Assignee:
            Nick Sieger
            Reporter:
            Joshua Nichols
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: