JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-3502

JRuby 1.2 and Rails 2.3.2 fails to db:create with ActiveRecord 0.9

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      All
    • Number of attachments :
      0

      Description

      I created a template app using the following combinations:

      1). JRuby 1.2.0 and Rails 2.2.2
      2). JRuby 1.2.0 and Rails 2.3.2
      3). JRuby 1.1.6 and Rails 2.2.2
      4). JRuby 1.1.6 and Rails 2.3.2

      For this template app, db:create creates the database for 1), 3), and 4) and not for 2). ActiveRecord-JDBCMySQL Adapter 0.9 is used.

        Activity

        Arun Gupta added a comment -

        This occurs only for jdbcmysql adapter, works fine for jdbcmysqlite3 adapter.

        kevin wells added a comment -

        i'm seeing a similar problem as well with ActiveRecord 0.9.1 and config #2. When i call rake db:create:all the command creates test and production but not development.

        abikounso added a comment -

        I have a similar problem with JRuby 1.3.0, Rails 2.3.2, and ActiveRecord-JDBCMySQL-Adapter 0.9.1.
        "rake db:create" doesn't work and terminal doesn't report any errors. When I call "rake db:create:all", creates only test database.

        Nick Sieger made changes -
        Field Original Value New Value
        Assignee Nick Sieger [ nsieger ]
        Michael Johann added a comment -

        For me the same issue with 1.3.1 and jdbcmysql and jdbcpostresql 0.9.1.
        I'm currently in a three day training talking about JRuby, so it's a bit of a surprise.
        Any hints on workarounds?
        I currently create the database manually.

        Arun Gupta added a comment -

        Not aware of a workaround, I'm creating the database manually as well.

        Dave Ray added a comment -

        I'm having the same problem with JRuby 1.3.1, ActiveRecord 0.9.1, Rails 2.3.3, and MySQL.
        db:create:all creates only test and production as noted above.
        db:drop:all does nothing.
        I'm glad I checked here because I thought I was going crazy

        Thomas E Enebo made changes -
        Component/s ActiveRecord-JDBC [ 12786 ]
        Thomas E Enebo made changes -
        Affects Version/s ActiveRecord-JDBC-0.9 [ 14818 ]
        Sang Shin added a comment -

        Any update on this problem? This is definitely a major bug...

        Charles Oliver Nutter added a comment -

        Maybe if we got this moved over to the kenai.com AR-JDBC project it would be more likely to get attention?

        http://kenai.com/projects/activerecord-jdbc

        Gytis Gurklys added a comment -

        Simple workaround for creating development db. I just copied existing env to a new environment called archive and now create:db:all creates dev env as well. Skips archive, of course .

        maarten bos added a comment -

        I got the same issue . it seems it is caused by the rails rake task

        {rails_gem}

        /lib/tasks/database.rake
        there is some adapter specific code in there. around line 56 there is the code: when 'mysql' . Changing it to a regular expression (like is allready done with sqlite) to 'when /mysql/' seems to have solved the problem for me.

        Nick Sieger added a comment -

        In 676f700.

        Nick Sieger made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Charles Oliver Nutter made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        yo added a comment -

        Issue in rails 2.3.4 and jruby 1.4.0RC2 with db:test:prepare. Work around with /mysql/ worked.


          People

          • Assignee:
            Nick Sieger
            Reporter:
            Arun Gupta
          • Votes:
            3 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: