Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JRuby 1.0.3
    • Fix Version/s: JRuby 1.6RC1
    • Component/s: Miscellaneous
    • Labels:
      None
    • Environment:
      AS/400 V5R3
    • Number of attachments :
      6

      Description

      The AS/400 contain Java environment and a AIX emulation environment. The latter provide sh and ksh but not bash, so the jruby script (and all the others requiring bash) do not work on this system.

      Is there any pressing need for requireing bash or would a regression to sh be reasonable?

      A proper raw sh implementation should run on every unix box in existance

      1. diff
        9 kB
        Gregory Seidman
      2. jruby_sh.patch
        2 kB
        Yannick "Pouype" Francois
      3. jruby.gz
        2 kB
        Thorbjørn Ravn Andersen
      4. jruby.sh
        9 kB
        Glauber Ribeiro
      5. me.patch
        2 kB
        Thomas E Enebo
      6. sh_jruby.patch
        1 kB
        Yannick "Pouype" Francois

        Issue Links

          Activity

          Glauber Ribeiro added a comment -

          Thomas, i removed all the Cygwin code, because i thought it didn't apply - i thought Cygwin people would run the Bash script. Was this a bad assumption? Also, i'm sure that sh script can use some improvement. I'll take a better look when i have time, but if anyone else would like to do it, i won't fell bad.

          Thomas E Enebo added a comment -

          I think the ultimate goal should be to just have one shell script which was on sh. A bash-specific one should get removed at some point once the sh one has parity.

          Charles Oliver Nutter added a comment -

          Tom: Agreed...for now we can have both, but I would love to see folks continue to bring the sh script into parity with the bash script. Seems like this is something we just have never been able to "big bang" into existence.

          Additional work should be done in separate bugs, since this one just required the existence of any sh script. We'll go forward from here.

          Glauber Ribeiro added a comment -

          OK, i'm working on this again... it really shouldn't take much to make this fully work with ksh and possibly sh.

          But i don't understand this syntax:

          http://glauber.pastebin.com/0xxuC7tF

          What does
          val=$

          {1:2}

          and $

          {val:0:4}

          mean?

          g

          Hiro Asari added a comment -

            People

            • Assignee:
              Charles Oliver Nutter
              Reporter:
              Thorbjørn Ravn Andersen
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: