JRuby (please use github issues at http://bugs.jruby.org)
  1. JRuby (please use github issues at http://bugs.jruby.org)
  2. JRUBY-1520

Upgrading Rubygems wipes out customizations, rarely works perfectly

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: JRuby 1.1.1
    • Fix Version/s: None
    • Component/s: Extensions
    • Labels:
      None
    • Environment:
      ruby 1.8.5 (2007-11-01 rev 4842) [i386-jruby1.1b1]
      CentOS 5
    • Number of attachments :
      0

      Description

      Trying to update to the latest beta gem release:

      [james@ceantar tst]$ gem update --system --source http://segment7.net/
      Updating RubyGems...
      Need to update 2 gems from http://segment7.net/
      ..
      complete
      Attempting remote update of rubygems-update
      Successfully installed rubygems-update-0.9.4.6
      Updating version of RubyGems to 0.9.4.6
      Installing RubyGems 0.9.4.6
      Error opening script file: setup.rb (No such file or directory)
      RubyGems system software updated
      [james@ceantar tst]$

      I didn't see this problem with MRI.

        Issue Links

          Activity

          Charles Oliver Nutter added a comment -

          We want to update to latest RubyGems for 1.1 final, but we should also allow this process to work.

          Charles Oliver Nutter added a comment -

          Ugh. I got something different, but much uglier:

          Installing rubygems-1.0.0 ri into /Users/headius/NetBeansProjects/jruby/lib/ruby/gems/1.8/doc/rubygems-1.0.0/ri...
          /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:222:in `markup': temporal locking already locked string (RuntimeError)
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:153:in `generate_method_info'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:133:in `generate_class_info'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:90:in `each'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:132:in `generate_class_info'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:90:in `process_class'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:94:in `process_class'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:93:in `each_classmodule'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/code_objects.rb:345:in `each_value'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/code_objects.rb:345:in `each_classmodule'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/code_objects.rb:345:in `process_class'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:93:in `generate'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:84:in `each'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:84:in `generate'
                  from /Users/headius/NetBeansProjects/jruby/lib/ruby/1.8/rdoc/generators/ri_generator.rb:84:in `document'
                  from setup.rb:202:in `run_rdoc'
                  from setup.rb:212:in `run_rdoc'
          RubyGems system software updated
          
          Vladimir Sizikov added a comment -

          I tried the command line mentioned in the description, and was able to upgrade to 0.9.4.7 version from 1.0.1, heh. And no questions asked. Then I tried to upgrade from the official place, and got back 1.0.1.

          The problem is that JRuby is shipped with slightly modified version of rubygems, and upgrading rubygems is not recommended.

          Vladimir Sizikov added a comment -

          Charlie commented that maybe we should disable the upgrade of rubygems for JRuby altogether.

          Charles Oliver Nutter added a comment -

          Removing target release from issues that fit any of the following criteria:

          • No known way to fix them
          • Java integration enhancements out of scope for 1.1 release
          • Other out of scope issues for 1.1
          Charles Oliver Nutter added a comment -

          I modified the title and marked this as still broken in 1.1.1, since there are customizations we have to make that get destroyed by a RubyGems update. Still an issue.

          Vladimir Sizikov added a comment -

          Marking this issue as duplicate of JRUBY-2607.

          We're almost there, having only 3 unresolved patches over official rubygems 1.1.2, none of which are critical.

          Vladimir Sizikov added a comment -

          Resolved as duplicate of JRUBY-2607.


            People

            • Assignee:
              Vladimir Sizikov
              Reporter:
              James Moore
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: