JiBX
  1. JiBX
  2. JIBX-98

java.lang.IllegalStateException: Internal error: Expected MyClass on stack, found MyClass[]

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: JiBX 1.0
    • Component/s: core
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Occurs during Compile step on a 16kb, somewhat deeply-nested binding.xml.
      Also tested current CVS version with same result.

      full stack:
      0: MyClass[]
      1: MyClass[]
      2: org.jibx.runtime.impl.UnmarshallingContext

      at org.jibx.binding.classes.MethodBuilder.verifyCompatible(MethodBuilder.java:393)
      at org.jibx.binding.classes.MethodBuilder.verifyCallStack(MethodBuilder.java:510)
      at org.jibx.binding.classes.MethodBuilder.appendCallVirtual(MethodBuilder.java:867)
      at org.jibx.binding.def.ObjectBinding.genUnmarshalCall(ObjectBinding.java:568)
      at org.jibx.binding.def.ObjectBinding.genUnmarshalContentCall(ObjectBinding.java:823)
      at org.jibx.binding.def.ObjectBinding.genContentUnmarshal(ObjectBinding.java:932)
      at org.jibx.binding.def.ComponentProperty.genContentUnmarshal(ComponentProperty.java:200)
      at org.jibx.binding.def.PassThroughComponent.genContentUnmarshal(PassThroughComponent.java:111)
      at org.jibx.binding.def.NestedCollection.genContentUnmarshal(NestedCollection.java:143)
      at org.jibx.binding.def.ObjectBinding.genUnmarshalContentCall(ObjectBinding.java:787)
      at org.jibx.binding.def.ObjectBinding.genContentUnmarshal(ObjectBinding.java:932)
      at org.jibx.binding.def.ComponentProperty.genContentUnmarshal(ComponentProperty.java:245)
      at org.jibx.binding.def.NestedStructure.genContentUnmarshal(NestedStructure.java:156)
      at org.jibx.binding.def.ObjectBinding.genUnmarshalContentCall(ObjectBinding.java:787)
      at org.jibx.binding.def.ObjectBinding.genContentUnmarshal(ObjectBinding.java:932)
      at org.jibx.binding.def.PassThroughComponent.genContentUnmarshal(PassThroughComponent.java:111)
      at org.jibx.binding.def.BaseMappingWrapper.genContentUnmarshal(BaseMappingWrapper.java:73)
      at org.jibx.binding.def.PassThroughComponent.genContentUnmarshal(PassThroughComponent.java:111)
      at org.jibx.binding.def.NestedStructure.genContentUnmarshal(NestedStructure.java:156)
      at org.jibx.binding.def.ObjectBinding.genUnmarshalContentCall(ObjectBinding.java:787)
      at org.jibx.binding.def.ObjectBinding.genContentUnmarshal(ObjectBinding.java:932)
      at org.jibx.binding.def.ComponentProperty.genContentUnmarshal(ComponentProperty.java:200)
      at org.jibx.binding.def.ElementWrapper.genContentUnmarshal(ElementWrapper.java:267)
      at org.jibx.binding.def.PassThroughComponent.genContentUnmarshal(PassThroughComponent.java:111)
      at org.jibx.binding.def.NestedStructure.genContentUnmarshal(NestedStructure.java:156)
      at org.jibx.binding.def.ObjectBinding.genUnmarshalContentCall(ObjectBinding.java:787)
      at org.jibx.binding.def.ObjectBinding.genContentUnmarshal(ObjectBinding.java:932)
      at org.jibx.binding.def.PassThroughComponent.genContentUnmarshal(PassThroughComponent.java:111)
      at org.jibx.binding.def.BaseMappingWrapper.genContentUnmarshal(BaseMappingWrapper.java:73)
      at org.jibx.binding.def.ElementWrapper.genContentUnmarshal(ElementWrapper.java:267)
      at org.jibx.binding.def.PassThroughComponent.genContentUnmarshal(PassThroughComponent.java:111)
      at org.jibx.binding.def.NestedStructure.genContentUnmarshal(NestedStructure.java:156)
      at org.jibx.binding.def.ObjectBinding.genUnmarshalContentCall(ObjectBinding.java:787)
      at org.jibx.binding.def.ObjectBinding.genContentUnmarshal(ObjectBinding.java:932)
      at org.jibx.binding.def.ElementWrapper.genContentUnmarshal(ElementWrapper.java:267)
      at org.jibx.binding.def.MappingDefinition.generateCode(MappingDefinition.java:592)
      at org.jibx.binding.def.DefinitionContext.generateCode(DefinitionContext.java:602)
      at org.jibx.binding.def.BindingDefinition.generateCode(BindingDefinition.java:611)
      at org.jibx.binding.Compile.compile(Compile.java:305)
      at org.jibx.binding.Compile.main(Compile.java:385)

        Activity

        Dennis Sosnoski added a comment -

        Can you supply at least a partial sample of your code and binding for this? It looks like the problem occurs in the binding for an array of MyClass.


          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Jonathan Taylor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: