JiBX
  1. JiBX
  2. JIBX-90

jibx soap client content-type="application/xml" not recognized by my weblogic server

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: jibxsoap-alpha0.2
    • Fix Version/s: jibxsoap-alpha0.2a
    • Component/s: JiBX/WS
    • Labels:
      None
    • Environment:
      winxp,java5
    • Number of attachments :
      0

      Description

      in SoapClient::call

      I found that changing the content-type to "text/xml" made it work with my weblogic server.

      I figured this out when I compared the http headers between jibx-soap and sun's-soap

        Activity

        Hide
        Eric Quilantang added a comment -

        it appears weblogic 8.1 sp3 is strict with the soap spec.
        it's okay with
        conn.setRequestProperty("Content-type","text/xml");
        or
        conn.setRequestProperty("Content-type","application/soap+xml");

        but it doesn't like application/xml

        Show
        Eric Quilantang added a comment - it appears weblogic 8.1 sp3 is strict with the soap spec. it's okay with conn.setRequestProperty("Content-type","text/xml"); or conn.setRequestProperty("Content-type","application/soap+xml"); but it doesn't like application/xml
        Hide
        Dennis Sosnoski added a comment -

        Fixed in jibxsoap-alpha-0.2a

        Show
        Dennis Sosnoski added a comment - Fixed in jibxsoap-alpha-0.2a

          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Eric Quilantang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: