JiBX
  1. JiBX
  2. JIBX-439

Jibx bindings not compiling separately in a Maven Multi Module project

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I have a project which is split in service & web module. So there are three poms. Now when we package the poms the TestNG test cases run fine but when we try to individually run the test cases it gives binding exception as below :

      Caused by: org.jibx.runtime.JiBXException: Unable to access binding information for class com.hilton.search.ws.response.GeocodeResponse
      Make sure the binding has been compiled
      at org.jibx.runtime.BindingDirectory.getBindingList(BindingDirectory.java:75)
      at org.jibx.runtime.BindingDirectory.getFactory(BindingDirectory.java:211)
      at com.hilton.search.ws.rest.JibxHttpMessageConverter.afterPropertiesSet(JibxHttpMessageConverter.java:106)
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1469)
      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1409)
      ... 83 more
      Caused by: java.lang.NoSuchFieldException: JiBX_bindingList
      at java.lang.Class.getDeclaredField(Unknown Source)
      at org.jibx.runtime.BindingDirectory.getBindingList(BindingDirectory.java:68)

      The Binding compiler plugin & its configuration is in service pom & the class is also in the service module so this should not be an issue.

      Could somebody help me on this as early as possible

        Activity

        Don Corley added a comment -

        Umang,

        There was a multi-module bug (JIBX-431) that was filed and fixed recently.

        Can you try your code with the latest version of JiBX:

        svn co https://jibx.svn.sourceforge.net/svnroot/jibx/trunk/plugins/maven-plugin/jibx-maven-plugin
        cd jibx-maven-plugin
        mvn install

        Remember to change your plugin name to jibx-maven-plugin (from maven-jibx-plugin) and update the revision number to 1.2.4-SNAPSHOT. jibx-maven-plugin is the new plugin name.

        Remember to build multi-module project from the parent project.

        You may also want to take a look at:
        http://jibx.sourceforge.net/jibx-maven-plugin/modular-codegen.html
        In 1.2.3 a new (easier) multi-module build procedure was introduced.

        If you can't get this to work, email me back and I'll release a bugfix (1.2.3.1) version.

        Don

        Don Corley added a comment -

        Fixed will be included in 1.2.4 code.


          People

          • Assignee:
            Don Corley
            Reporter:
            Umang Singh
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: