JiBX
  1. JiBX
  2. JIBX-437

Conflicting element namespaces error incorrectly reported

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: JiBX 1.2.3
    • Fix Version/s: JiBX 1.2.3
    • Component/s: core
    • Labels:
      None
    • Number of attachments :
      0

      Description

      When trying to compile this binding:

      <?xml version="1.0" encoding="ISO-8859-1"?>
      
      <!-- $Id: status.xml 6 2010-09-28 22:07:31Z archie.cobbs $ -->
      <binding package="org.dellroad.jibxbindings.pidf"
        xmlns:pidf="urn:ietf:params:xml:ns:pidf"
        xmlns:gp="urn:ietf:params:xml:ns:pidf:geopriv10">
          <include path="lo/geoPriv.xml"/>
          <mapping abstract="true" type-name="pidf:status" class="org.dellroad.jibxbindings.pidf.Status">
              <namespace uri="urn:ietf:params:xml:ns:pidf" default="elements" prefix="pidf"/>
              <namespace uri="urn:ietf:params:xml:ns:pidf:geopriv10" default="elements" prefix="gp"/>
              <value name="basic" ns="urn:ietf:params:xml:ns:pidf" field="basic" usage="optional" enum-value-method="getXMLValue"/>
              <structure name="geopriv" ns="urn:ietf:params:xml:ns:pidf:geopriv10" field="geoPriv" map-as="gp:geopriv" usage="optional"/>
          </mapping>
      </binding>
      

      JiBX generates this error:

      Error: Conflicting element namespaces; on namespace element at (line 10, col 96, in status.xml)
      

      The error is incorrect: the two namespaces have different prefixes. Therefore this is a bug.

      This bug does not occur in JiBX 1.2.2.

        Activity

        Archie Cobbs added a comment -

        OK, now I realize I think this is happening not because of a namespace conflict but because both namespaces have default="elements". I guess JiBX 1.2.2 simply didn't detect this problem.

        Sorry for the noise, please mark this issue INVALID.

        Archie Cobbs made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s JiBX 1.2.3 [ 16349 ]
        Resolution Not A Bug [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Archie Cobbs
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: