JiBX
  1. JiBX
  2. JIBX-379

org.jibx.schema.elements.GroupRefElement cannot be cast to org.jibx.schema.elements.CommonCompositorDefinition

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: JiBX 1.2.2
    • Fix Version/s: None
    • Component/s: CodeGen
    • Labels:
      None
    • Environment:
      Windows XP
    • Testcase included:
      yes
    • Number of attachments :
      1

      Description

      I think this is the same as the supposedly fixed bug 363. I get the error message in the summary when running CodeGen from the command line on the attached xsd.

      The bug is critical for me in that it simply keeps me from trying jibx - which given its performance claims I would very much like to do.

      Your help is very much appreciated!

      --Arend

        Activity

        Dennis Sosnoski added a comment -

        Duplicate of JIBX-363. I've verified that the schema works with the current CVS code. I've also updated the 1.2.3-SNAPSHOT jars in the maven repository at http://jibx.sourceforge.net/maven/jibx/jars/ so you can download the jars from there and try them directly if you don't want to build from source. The official 1.2.3 release will be out soon.

        Dennis Sosnoski made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Dennis Sosnoski [ dsosnoski ]
        Resolution Duplicate [ 3 ]
        Dennis Sosnoski made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Arend Rensink
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: