JiBX
  1. JiBX
  2. JIBX-362

Maven JiBX Plugin doesn't search subdirectories

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JiBX 1.2.1
    • Fix Version/s: JiBX 1.2.3
    • Component/s: maven plugin
    • Labels:
      None
    • Environment:
      maven-jibx-plugin 1.2.1
      Maven version: 2.0.9
      Java version: 1.6.0_10
      OS name: "windows xp" version: "5.1" arch: "x86" Family: "windows"
    • Number of attachments :
      0

      Description

      When using the maven jibx plugin, I can only get JiBX to find binding files when I use the full path. It does not search subdirectories.

      When I have my pom with:
      <plugin>
      <groupId>org.jibx</groupId>
      <artifactId>maven-jibx-plugin</artifactId>
      <version>1.2.1</version>
      <configuration>
      <directory>src/main/java/com/xxx/xxx/xxx/xxx/xxx/xxx/xxx</directory>
      <includes>
      <includes>*-jibx.xml</includes>
      </includes>
      <verbose>false</verbose>
      </configuration>
      <executions>
      <execution>
      <goals>
      <goal>bind</goal>
      </goals>
      </execution>
      </executions>
      </plugin>

      it finds the file. The output is: Running JiBX binding compiler (single-module mode) on 1 binding file(s)

      But if I even go up one directory and add "**/" to my includes, it doesn't work. It doesn't find the file.
      <directory>src/main/java/com/uprr/app/uit/portal/tey/train</directory>
      <includes>
      <includes>*/-jibx.xml</includes>
      </includes>

      Output is: Not running JiBX binding compiler (single-module mode) - no binding files

        Issue Links

          Activity

          Dennis Sosnoski made changes -
          Field Original Value New Value
          Assignee Jerome Bernard [ kalixia ]
          Don Corley made changes -
          Link This issue duplicates JIBX-123 [ JIBX-123 ]
          Don Corley added a comment -

          This is a duplicate of issue JIBX-123

          Don Corley made changes -
          Assignee Jerome Bernard [ kalixia ] Don Corley [ doncorley ]
          Don Corley added a comment -

          Resolved (duplicate) JIBX-123

          Don Corley made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s JiBX 1.2.3 [ 16349 ]
          Resolution Fixed [ 1 ]

            People

            • Assignee:
              Don Corley
              Reporter:
              Adam Koch
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: