JiBX
  1. JiBX
  2. JIBX-352

outOfMemory error while unmarshalling large xml file (500 mb)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: JiBX 1.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      256 mb heap size, windows xp,
    • Number of attachments :
      0

      Description

      I am unmarshalling large xml file size 500 mb. While unmarshalling jibx is giving outOfMemoryExceptipn.

        Activity

        Dennis Sosnoski added a comment -

        Is there some reason you believe this to be a bug? Depending on the actual XML document, a 500 mb document can easily take more than 256 mb of memory. Just reading the document into memory would take about 1 gb (since each byte of input text is normally converted into a two-byte character in Java).


          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            satish singh
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: