JiBX
  1. JiBX
  2. JIBX-328

Jira error coming due to appending into the jar of compilation of linked xml file.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: JiBX 1.2.1
    • Fix Version/s: JiBX 1.2.1
    • Component/s: maven plugin
    • Labels:
      None
    • Environment:
      Window XP
    • Number of attachments :
      0

      Description

      I have created one Class in a Maven project suppose project1 and also written "binding" file for that class and complied by Jibx maven plugin . I have created another project suppose project2 and extending that class into this project class such as

      project1.CalssTwo extends project2.ClassOne
      and added maven dependencies of Project1.

      I have written binding file for the ClassTwo and in that i am calling the binding file of ClassOne which is present into the project1 as
      <import path="project1/src/java/resource/binding.xml" precompield="true"/>
      or
      <import path="project1/src/java/resource/binding.xml" />
      now when i compeld it through maven plugin it is showing BUILD ERROR because of it cant't write into the project1.jar and jira error is showing.

      I am not understanding why it wants to write into the Jar and also when it has already written(binding) into that jar cant it read and work as like Java inheritance.

        Activity

        Dennis Sosnoski added a comment -

        Without seeing the binding it's hard to say what's going wrong, but the most likely cause is that you're working directly with ClassOne in your ClassTwo binding. See this email discussion for an example: http://www.mail-archive.com/jibx-users%40lists.sourceforge.net/msg04175.html

        Dennis Sosnoski made changes -
        Field Original Value New Value
        Assignee Dennis Sosnoski [ dsosnoski ]
        Remaining Estimate 4 days [ 345600 ]
        Original Estimate 4 days [ 345600 ]
        Testcase included yes
        Dennis Sosnoski made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Abhilash Ranjan
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: