JiBX
  1. JiBX
  2. JIBX-321

Jira error coming due to appending into the jar.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: JiBX 1.2.1
    • Fix Version/s: JiBX 1.2.2
    • Component/s: maven plugin
    • Labels:
      None
    • Environment:
      Windows XP
    • Number of attachments :
      0

      Description

      I have created one Class in a Maven project suppose project1 and also written "binding" file for that class and complied by Jibx maven plugin . I have created another project suppose project2 and extending that class into this project class such as

      project1.CalssTwo extends project2.ClassOne
      and added maven dependencies of Project1.

      I have written binding file for the ClassTwo and in that i am calling the binding file of ClassOne which is present into the project1 as
      <import path="project1/src/java/resource/binding.xml" precompield="true"/>
      or
      <import path="project1/src/java/resource/binding.xml" />
      now when i compeld it through maven plugin it is showing BUILD ERROR because of it cant't write into the project1.jar and jira error is showing.

      I am not understanding why it wants to write into the Jar and also when it has already written(binding) into that jar cant it read and work as like Java inheritance.

        Activity

        Dennis Sosnoski added a comment -

        Duplicate of JIBX-328


          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Abhilash Ranjan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: