JiBX
  1. JiBX
  2. JIBX-270

StaXWriter truncates output after a couple of thousand lines

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: JiBX 1.2
    • Component/s: core
    • Labels:
      None
    • Number of attachments :
      0

      Description

      After changing JiBX/WS to try out the StaXWriter, large response payloads were truncated after a couple of thousand lines.

      The change I tried was in WsServletDelegate.getNormalWriter():

      try

      { XMLOutputFactory ofact = javax.xml.stream.XMLOutputFactory.newInstance(); XMLStreamWriter wrtr = ofact.createXMLStreamWriter(m_response.getOutputStream()); return new StAXWriter(m_writer.getNamespaces(), wrtr); }

      catch (XMLStreamException e)

      { throw new IOException("Error creating writer " + e.getMessage()); }

      // return m_writer;

        Activity

        Nigel Charman added a comment -

        I've been unable to reproduce it too. Tried with and without xpp3, and with seismic example parameters as 1, 100


          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Nigel Charman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: