JiBX
  1. JiBX
  2. JIBX-262

add Schema-level customization attributes: add-prefix, add-suffix

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: JiBX 1.2
    • Fix Version/s: None
    • Component/s: core
    • Labels:
      None
    • Number of attachments :
      0

      Description

      add-prefix:
      Prefix string to be added from schema names before converting to Java names. The value is a prefix string.

      add-suffix:
      Suffix strings to be added from schema names before converting to Java names. The value is a suffix string.

      e.g.:
      <xsd:complexType name="RelationType">
      <xsd:sequence>
      <xsd:element name="id" type="xsd:string" />
      <xsd:element name="name" type="xsd:string" />
      </xsd:sequence>
      </xsd:complexType>

      should result in a class named RelationTypeDTO

      public class RelationTypeDTO

      { private String id; private String name; ... }

        Activity

        Dennis Sosnoski added a comment -

        Duplicate of JIBX-261


          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            maria aschauer
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: