JiBX
  1. JiBX
  2. JIBX-229

Stack error during compilation

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: JiBX 1.2.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      Linux, java 1.4
    • Number of attachments :
      2

      Description

      While compiling the xmlbinding file with jibx 1.0ORCO the following error occurs. When I use jibx_1_1_6a another error is thrown which is given at the bottom.
      The xmlbinding file and the related java codes are attached.
      xmlbind:
      [bind] Failed setting classpath from Ant task
      [bind] Using the following paths:
      [bind] /space/workcvs/CUSTOM/customization/customization/turkey/avea/mmsc/charging/$

      {java.classes}
      [bind] Using the following binding paths:
      [bind] /space/workcvs/CUSTOM/customization/customization/turkey/avea/mmsc/charging/schema/promo-binding.xml
      [bind] Running binding compiler version jibx-rc0
      [bind] binding promo_binding:
      [bind] context (mp#=5) (cv#=0) (fm#=0)
      [bind] mapping class com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.DebitPromoRequest to element DEBIT_PROMO_REQ
      [bind] element wrapper DEBIT_PROMO_REQ
      [bind] object binding for com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.DebitPromoRequest
      [bind] structure ordered
      [bind] element SERVICENAME from property serviceName (java.lang.String)
      [bind] element SENDER from property sender (java.lang.String)
      [bind] element wrapper RECIPIENTS
      [bind] component property recipients (java.util.ArrayList)
      [bind] object binding for java.util.ArrayList
      [bind] collection ordered
      [bind] mapping reference to com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.Recipient using property from collection (com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.Recipient)
      [bind] mapping class com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.DebitPromoResponse to element DEBIT_PROMO_RES
      [bind] element wrapper DEBIT_PROMO_RES
      [bind] object binding for com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.DebitPromoResponse
      [bind] structure ordered
      [bind] element RETURN_CODE from property returnCode (java.lang.String)
      [bind] element RETURN_TEXT from optional property returnText (java.lang.String)
      [bind] element PROMO_RESULT from optional property promoResult (java.lang.String)
      [bind] element PROMO_ID from optional property promoId (java.lang.String)
      [bind] mapping class com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.RefundPromoRequest to element REFUND_PROMO_REQ
      [bind] element wrapper REFUND_PROMO_REQ
      [bind] object binding for com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.RefundPromoRequest
      [bind] structure ordered
      [bind] element SERVICENAME from property serviceName (java.lang.String)
      [bind] element SENDER from property sender (java.lang.String)
      [bind] element PROMO_ID from property promoId (java.lang.String)
      [bind] mapping class com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.RefundPromoResponse to element REFUND_PROMO_RES
      [bind] element wrapper REFUND_PROMO_RES
      [bind] object binding for com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.RefundPromoResponse
      [bind] structure ordered
      [bind] element RETURN_CODE from property returnCode (java.lang.String)
      [bind] element RETURN_TEXT from optional property returnText (java.lang.String)
      [bind] mapping class com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.Recipient to element RECIPIENT
      [bind] element wrapper RECIPIENT
      [bind] object binding for com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.Recipient
      [bind] structure ordered
      [bind] element ADDRESS from property address (java.lang.String)
      [bind] element MNP_PREFIX from optional property mnpPrefix (java.lang.String)
      [bind] Generating code for mapping com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.DebitPromoRequest
      [bind] Error running binding compiler

      [bind] *** Error during code generation - please report this error on the JiBX users list so that the condition can be caught during validation ***

      [bind] java.lang.IllegalStateException: Internal error: Expected java.lang.String on stack, found com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.DebitPromoRequest
      [bind] full stack:
      [bind] 0: com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.DebitPromoRequest
      [bind] 1: com.telenity.canvas.mmsc.charging.avea.iwis.promotion.xmlmessage.DebitPromoRequest

      [bind] at org.jibx.binding.classes.MethodBuilder.verifyCompatible(MethodBuilder.java:409)
      [bind] at org.jibx.binding.classes.MethodBuilder.verifyStack(MethodBuilder.java:447)
      [bind] at org.jibx.binding.classes.MethodBuilder.appendPutStatic(MethodBuilder.java:756)
      [bind] at org.jibx.binding.classes.MethodBuilder.appendPut(MethodBuilder.java:770)
      [bind] at org.jibx.binding.def.PropertyDefinition.genStore(PropertyDefinition.java:520)
      [bind] at org.jibx.binding.def.ValueChild.genUnmarshal(ValueChild.java:452)
      [bind] at org.jibx.binding.def.ValueChild.genContentUnmarshal(ValueChild.java:680)
      [bind] at org.jibx.binding.def.NestedStructure.genContentUnmarshal(NestedStructure.java:153)
      [bind] at org.jibx.binding.def.ObjectBinding.genUnmarshalContentCall(ObjectBinding.java:736)
      [bind] at org.jibx.binding.def.ObjectBinding.genContentUnmarshal(ObjectBinding.java:875)
      [bind] at org.jibx.binding.def.ElementWrapper.genContentUnmarshal(ElementWrapper.java:272)
      [bind] at org.jibx.binding.def.MappingDefinition.generateCode(MappingDefinition.java:541)
      [bind] at org.jibx.binding.def.DefinitionContext.generateCode(DefinitionContext.java:600)
      [bind] at org.jibx.binding.def.BindingDefinition.generateCode(BindingDefinition.java:578)
      [bind] at org.jibx.binding.Compile.compile(Compile.java:303)
      [bind] at org.jibx.binding.ant.CompileTask.execute(CompileTask.java:248)
      [bind] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
      [bind] at org.apache.tools.ant.Task.perform(Task.java:364)
      [bind] at org.apache.tools.ant.Target.execute(Target.java:341)
      [bind] at org.apache.tools.ant.Target.performTasks(Target.java:369)
      [bind] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
      [bind] at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
      [bind] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
      [bind] at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
      [bind] at org.apache.tools.ant.Main.runBuild(Main.java:668)
      [bind] at org.apache.tools.ant.Main.startAnt(Main.java:187)
      [bind] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
      [bind] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
      ############################
      FOR jibx_1_1_6a
      xmlbind:
      [bind] Failed setting classpath from Ant task
      [bind] Using the following paths:
      [bind] /space/workcvs/CUSTOM/customization/customization/turkey/avea/mmsc/charging/${java.classes}

      [bind] Using the following binding paths:
      [bind] /space/workcvs/CUSTOM/customization/customization/turkey/avea/mmsc/charging/schema/promo-binding.xml
      [bind] Running binding compiler version jibx_1_1_6a
      [bind] Error running binding compiler

      [bind] *** Error during code generation for file 'promo-binding.xml' - please enter a bug report for this error in Jira if the problem is not listed as fixed on the online status page ***

      [bind] org.jibx.runtime.JiBXException: One or more <mapping> elements for modifiable classes must be defined in <binding>
      [bind] at org.jibx.binding.Utility.loadBinding(Utility.java:317)
      [bind] at org.jibx.binding.Utility.loadFileBinding(Utility.java:408)
      [bind] at org.jibx.binding.Compile.compile(Compile.java:296)
      [bind] at org.jibx.binding.ant.CompileTask.execute(CompileTask.java:248)
      [bind] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
      [bind] at org.apache.tools.ant.Task.perform(Task.java:364)
      [bind] at org.apache.tools.ant.Target.execute(Target.java:341)
      [bind] at org.apache.tools.ant.Target.performTasks(Target.java:369)
      [bind] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
      [bind] at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
      [bind] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
      [bind] at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
      [bind] at org.apache.tools.ant.Main.runBuild(Main.java:668)
      [bind] at org.apache.tools.ant.Main.startAnt(Main.java:187)
      [bind] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
      [bind] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)

        Activity

        Dennis Sosnoski added a comment -

        Verified that this works with the 1.2.2 code.


          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Gokhan Karadag
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: