JiBX
  1. JiBX
  2. JIBX-210

JiBX exception with special chars in binding file name

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: JiBX 1.1.6
    • Component/s: core
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I have multiple binding files for a single class. When selecting the proper binding file with the BindingDirectory.getFactory(Class targetClass, String bindingName) i get the following exception:

      org.jibx.runtime.JiBXException: Binding information for class xyz.MyTargetClass must be regenerated with current binding compiler at org.jibx.runtime.BindingDirectory.getFactoryFromName(BindingDirectory.java:134) at org.jibx.runtime.BindingDirectory.getFactory(BindingDirectory.java:211)

      I had a debugging session on this, for more details see my blog: http://twelve-programmers.blogspot.com/2008/03/jibx-exception-with-special-chars-in.html

      I found out that a "-" character in my binding file name was the root cause for the problem. Jibx should check binding names for illegal characters, that are not allowed as Java class names.
      This check should happen while running the binding compiler.

        Activity

        Dennis Sosnoski added a comment -

        Fixed for 1.1.6. Thanks for pointing this out!

        Dennis Sosnoski made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Assignee Dennis Sosnoski [ dsosnoski ]
        Dennis Sosnoski made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Jan Lisse
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: