JiBX
  1. JiBX
  2. JIBX-205

binding compiler is not aware of inherited interfaces

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: JiBX 1.1.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Consider the following:- (This is similar to Bug JIBX-156)

      public interface IFoo
      { }

      public interface IBar extends IFoo
      { }

      public class Bug_Test implements IBar { }

      If I have structure field which is of type IFoo, it fails to realize that Bug_Test is actually implementing it indirectly and throws the error:-
      Error: No compatible mapping defined for type IFoo;

      However, if I have a seperate mapping for IBar, it realizes that IBar extends to IFoo and eventually realizes that Bug_Test is implementing. It is similar to the above issue with the exception of interface instead of abstract class.

      Is there a bug fix available ?

        Activity

        Dennis Sosnoski added a comment -

        Duplicate of JIBX-202


          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Jaquar
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: