JiBX
  1. JiBX
  2. JIBX-120

Provide more context when internal errors occur

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: JiBX 1.1
    • Fix Version/s: JiBX 1.1.2
    • Component/s: core
    • Labels:
      None
    • Number of attachments :
      1

      Description

      I've come across a few "Internal errors" while trying to upgrade from beta3c to jibx 1.1. Since I'm compiling a long list of binding files, it would be helpful in narrowing down the problem if the "internal error" message told me which binding caused the problem. So, instead of:

          • Error during code generation - please enter a bug report for this error in Jira if the problem is not listed as fixed on the online status page ***

      It could say:

          • Error during code generation for binding file 'binding_hotels.xml' - please enter a bug report for this error in Jira if the problem is not listed as fixed on the online status page ***

        Activity

        Joshua Davies added a comment -

        Proposed patch

        Dennis Sosnoski added a comment -

        Added the file name to the output message. Thanks for pointing this out, Joshua.


          People

          • Assignee:
            Dennis Sosnoski
            Reporter:
            Joshua Davies
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: