Jetty
  1. Jetty
  2. JETTY-939

NPE in AbstractConfiguration.callPreDestroyCallbacks

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.1.15.rc5
    • Fix Version/s: 6.1.15
    • Component/s: J2EE/Extra
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Null pointer when destroying a context:

      java.lang.NullPointerException

      at
      org.mortbay.jetty.plus.webapp.AbstractConfiguration.callPreDestroyCallbacks(AbstractConfiguration.java:470)
      at
      org.mortbay.jetty.plus.webapp.AbstractConfiguration.deconfigureWebApp(AbstractConfiguration.java:104)
      at
      org.mortbay.jetty.plus.webapp.Configuration.deconfigureWebApp(Configuration.java:138)
      at
      org.mortbay.jetty.webapp.WebAppContext.doStop(WebAppContext.java:492)
      at
      org.mortbay.component.AbstractLifeCycle.stop(AbstractLifeCycle.java:65)
      at
      org.mortbay.jetty.handler.HandlerCollection.doStop(HandlerCollection.java:164)
      at
      org.mortbay.component.AbstractLifeCycle.stop(AbstractLifeCycle.java:65)
      at
      org.mortbay.jetty.handler.HandlerCollection.doStop(HandlerCollection.java:164)
      at
      org.mortbay.component.AbstractLifeCycle.stop(AbstractLifeCycle.java:65)
      at
      org.mortbay.jetty.handler.HandlerWrapper.doStop(HandlerWrapper.java:129)
      at
      org.mortbay.component.AbstractLifeCycle.stop(AbstractLifeCycle.java:65)
      at
      org.mortbay.jetty.handler.HandlerWrapper.doStop(HandlerWrapper.java:129)
      at org.mortbay.jetty.Server.doStop(Server.java:270) at
      org.mortbay.component.AbstractLifeCycle.stop(AbstractLifeCycle.java:65)
      at
      org.mortbay.jetty.Server$ShutdownHookThread.run(Server.java:548)

        Activity

        Jan Bartel added a comment -

        I can't reproduce this with the most recent jetty-6 release, but nevertheless I added a couple of NPE protections into AbstractConfiguration. See svn rev 4708.

        Jan Bartel added a comment -

        Also ported to jetty-7 as rev 4710.


          People

          • Assignee:
            Jan Bartel
            Reporter:
            Jan Bartel
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: